1

I had Ubuntu 13.10 which worked just fine. I've decided to try 14.04. I've done an upgrade and when it finished, it booted to desktop but my keyboard and mouse didn't work at all. So I've decided to try a clean install instead. I've downloaded the iso for 14.04.1 (64 bit), checked it's md5 checksum and made a live usb drive from it. It booted just fine and finished the installation without issues. When finished, it booted to the desktop but again, the mouse and keyboard don't work at all.

I've tried the advanced options, managed to boot using the failsafeX option and the mouse and the keyboard both worked. They also show up with lsusb.

The mouse and the keyboard are wireless, made by logitech.

What can I do now? I suspect this is a driver issue but I don't know linux well enough to tell compare configurations during regular boot which doesn't work and the live version which does.

3

I too had this problem not 10 minutes ago. The way I solved it is by rebooting into an older version of the GNU/Linux kernel (It should have an option for that in grub). Then running sudo apt-get dist-upgrade.

  • @Yakov: Remember to accept the answer by clicking on the check mark beside the answer. – Charo Aug 29 '14 at 17:24
  • Glad I could help! :D – Finn O'leary Aug 30 '14 at 19:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.