I've finally found why my Google Chrome is so slow. And I've found these 2 posts. The first on Google Chrome forum and the second one here. The solution suggested in the second post requires a modification of /etc/modprobe.d/aliases, but on my Ubuntu 11.04 I don't have such a file.

None of the resources i found would work on 11.04. Can anyone use anything that has worked and which is easily revertible?

Below are the result of dig aaaa he.net and dig a he.net

joseph@joseph-off-lap:~$ dig aaaa he.net

; <<>> DiG 9.7.3 <<>> aaaa he.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15618
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 7

;he.net.                IN  AAAA

he.net.         58616   IN  AAAA    2001:470:0:76::2

he.net.         2031    IN  NS  ns2.he.net.
he.net.         2031    IN  NS  ns3.he.net.
he.net.         2031    IN  NS  ns4.he.net.
he.net.         2031    IN  NS  ns5.he.net.
he.net.         2031    IN  NS  ns1.he.net.

ns1.he.net.     2044    IN  A
ns2.he.net.     2044    IN  A
ns2.he.net.     73027   IN  AAAA    2001:470:200::2
ns3.he.net.     2044    IN  A
ns3.he.net.     62719   IN  AAAA    2001:470:300::2
ns4.he.net.     2044    IN  A
ns4.he.net.     62719   IN  AAAA    2001:470:400::2

;; Query time: 134 msec
;; WHEN: Mon Jul  4 17:02:33 2011
;; MSG SIZE  rcvd: 290

joseph@joseph-off-lap:~$ dig a he.net

; <<>> DiG 9.7.3 <<>> a he.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31069
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 7

;he.net.                IN  A

he.net.         58533   IN  A

he.net.         1948    IN  NS  ns4.he.net.
he.net.         1948    IN  NS  ns5.he.net.
he.net.         1948    IN  NS  ns1.he.net.
he.net.         1948    IN  NS  ns2.he.net.
he.net.         1948    IN  NS  ns3.he.net.

ns1.he.net.     1961    IN  A
ns2.he.net.     1961    IN  A
ns2.he.net.     72944   IN  AAAA    2001:470:200::2
ns3.he.net.     1961    IN  A
ns3.he.net.     62636   IN  AAAA    2001:470:300::2 
ns4.he.net.     1961    IN  A
ns4.he.net.     62636   IN  AAAA    2001:470:400::2

;; Query time: 190 msec
;; WHEN: Mon Jul  4 17:03:56 2011
;; MSG SIZE  rcvd: 278

below are the result for ping and ping6

joseph@joseph-off-lap:~$ ping -c 5 he.net
PING he.net ( 56(84) bytes of data.
64 bytes from he.net ( icmp_req=1 ttl=45 time=277 ms
64 bytes from he.net ( icmp_req=2 ttl=45 time=275 ms
64 bytes from he.net ( icmp_req=3 ttl=45 time=277 ms
64 bytes from he.net ( icmp_req=4 ttl=45 time=275 ms
64 bytes from he.net ( icmp_req=5 ttl=45 time=275 ms

--- he.net ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 21209ms
rtt min/avg/max/mdev = 275.675/276.405/277.621/0.995 ms

joseph@joseph-off-lap:~$ ping6 -c 5 he.net
connect: Network is unreachable

as suggested i'm leaning towards installing miredo .is there any configurations/tweaks to make it works? what would you say about disabling ipv6 vs installing miredo ?

thanks for reading this. ;)

  • No! Guides for other Ubuntu OS's prior to Natty 9 out of 10 are no longer valid.
    – Rinzwind
    Jul 4, 2011 at 14:01
  • mmh sorry what does that mean? Jul 4, 2011 at 14:06
  • That the guide you found will not work for Natty.
    – Rinzwind
    Jul 4, 2011 at 15:05
  • any work around out there? Jul 4, 2011 at 15:44
  • Instead of disabling IPv6, we should fix whatever the problem is.
    – Azendale
    Jul 4, 2011 at 16:38

3 Answers 3


When Chrome is slow to start loading the page but once it starts loading the page it's fast, there are two things that could be going wrong. The first possibility is that your computer is using a buggy DNS server that doesn't handle requests for IPv6 addresses well. The second possibility is that your computer thinks it has internet IPv6 connectivity when in reality it doesn't.

Run dig aaaa he.net and dig a he.net. Each one will list a Query time. The times should be within ~200msec of each other. If they are not, you DNS server is what is causing this slowness.

One case to test for is how fast the DNS server will tell you that a website does not have an IPv6 address. You can test this by running something like dig aaaa bluecc.edu. It's Query time should be similar to the other times you ran 'dig'. The important thing is that the Query time is short.

IPv6 access itself could be broken. You can test by running ping -c 5 he.net and ping6 -c 5 he.net. The 'time' for the ping6 should be comparable to just ping, and the 'time' should be at least less 1000 msec. If the ping6 is giving you destination unreachable errors, then your IPv6 connectivity is broken. In that case, you have two options. One is to disable IPv6 and the other is to install miredo, which will make an IPv6 tunnel, which should fix any connectivity problems. (You shouldn't have to do anything to set up miredo. It should just work. It's also easy to remove if you ever need to with sudo apt-get remove miredo)

  • thanks will do that.should i put the result here? Jul 4, 2011 at 17:02
  • Yes. If you find out more facts about your problem, it doesn't hurt to add them to your question so that people have a better idea of what is happening.
    – Azendale
    Jul 4, 2011 at 17:10
  • what do you mean with this question "Is Chromium slow to open?". let me describe how it's starts.first it's google chrome stable(not chromium).and i have 5 sites that open when browser starts.the browser itself opens withing 2seconds and then the tabs show "loading" for quite a while and when the titles come up the pages load relatively faster.same for refresh of the same page Jul 4, 2011 at 18:21
  • i've updated the question to include the result of ping vs ping6.and as you have guest it, ipv6 connectivity is broken. Jul 5, 2011 at 7:25
  • i've tried miredo for like 3 days and i found the connection still slow.i've now removed it and disable the ipv6 protocol in the /etc/default/grug this morning and it seems effective already. Jul 8, 2011 at 11:10

For the record, disabling IPv6 can be done by setting the following in /etc/default/grub:


Don't forget to call update-grub afterwards and reboot. This seems to be the most sure-fire way to do it in Ubuntu.

Another way is to set it in /etc/sysctl.conf:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1

To disable IPv6 immediately, but not permanently, without reboot:

# sysctl -w net.ipv6.conf.all.disable_ipv6=1
# sysctl -w net.ipv6.conf.default.disable_ipv6=1

I've found that using /etc/sysctl.conf didn't work as expected but I don't exactly remember what the problem was. Maybe the settings were applied too late in the boot process for some applications?

  • 1
    GRUB_CMDLINE_LINUX="ipv6.disable=1" disables the module completely from being loaded.
    – wojox
    Jul 4, 2011 at 20:39

I followed the instructions here: http://www.webupd8.org/2010/05/how-to-disable-ipv6-in-ubuntu-1004.html

It worked perfectly on 10.04, 10.10 and 11.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.