0

I have exactly this problem. I retype some of it in case link goes offline. I have notebook lenovo E540. I think I'm using 14.04.1 LTS (didn't check) and kernel 3.13.0-35. My wifi stoped working after few minutes and I could not get it going. So I googled for the solution. I found this:

From there I tried the solution in #29

I have tried the following on several kernels (under 12.04 and 14.04) and so far it has worked well :sudo apt-get install linux-headers-generic build-essential git
# needed only if you don't have yet that package
git clone http://github.com/lwfinger/rtl8723be
# needed only if you don't have yet downloaded rtl8723be
cd rtl8723be
git checkout 604aa9058fb9e5bb1cf571c99989d081f8fc8b9
make clean
make
sudo make install
sudo modprobe rtl8723be
echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

But it broke my system. I get kernel panic because of rtl8723be driver. I try to load to recovery mode -> root shell and run:

modprobe -r rtl8723be

No output. Didn't help. How do I remove that driver from system? I would like to avoid reinstalling whole system.

3
  • what about blacklist it in /etc/modprobe.d/blacklist?
    – AlexGreg
    Aug 29 '14 at 12:21
  • 1
    Thanks a lot! That works. I had to overcome read-only filesystem in recovery root shell, then added line blacklist rtl8723be into blacklist.conf file. Thanks again! (PS: why didn't you post it as answer? )
    – Lucas03
    Aug 29 '14 at 19:37
  • Sorry for my stupid question I just noticed its written in comment 30. :(
    – Lucas03
    Aug 29 '14 at 19:48
0

I found this solution, and worked perfectly on a Lenovo g40-30 so i guess it should work in other lenovo pc...

quote:

for one time test:

sudo rmmod ideapad_laptop

for working after reboot:

echo "blacklist ideapad_laptop" | sudo tee -a /etc/modprobe.d/blacklist-ideapad.conf

found it in: Wifi Not Working On Ubuntu 14.04 Lenovo G 50-30

but I don't know if you'll have to unistall the module you installed. Try it, or try to update your kernel, then the solution I found.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.