According to: http://wiki.secondlife.com/wiki/Linux_Viewer#Installing_and_Running

The Second Life Linux client entirely runs out of the directory you have unpacked it into - no installation step is required.

How is that possible? Isn't that a security risk?

I tried it, and it indeed ran without installing anything, I didn't have to type in my password to install it or anything. It just launched. Double clicking the application even created an entry in Unity. I tried this on Ubuntu 12.04.

2 Answers 2


If an application doesn't require root to install, then the application is in fact "safer" (I quoted safer because, in general, an application can still be harmful if you don't know what it does whether you used sudo or not. e.g. Maybe it will sniff around your home directory and start uploading some confidential data, and you wouldn't need root access for that).

What you quoted means that you can unpack the game anywhere you want and start using it directly. Since your home directory is yours, then unpacking in your home directory does not require sudo.

Since you installed the game without sudo, then that just means the game doesn't need access to any of the system directories (i.e. safer).


The game is installed in a directory owned by the user who installs it and runs with privileges from that user.

For this method to become to start to be a problem you need to be asked the admin password and provide it. So

  1. never run this program with sudo or as root.
  2. never install this program with sudo or as root.
  3. when prompted for an admin password post about it on google+ ;)

and you'll be fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .