The installer threw an error near the end of the 14.04 Trusty upgrade. unity-control-center is not installed and upon trying to install it I now have a chain of broken dependencies which, after going several dependencies deep, end in messages similar to
libegl1-mesa-drivers : Depends: libegl1-mesa (= 10.1.3-0ubuntu0.1) but 10.3.0~git20140618.88b887fa-0ubuntu0ricotz~saucy is to be installed.
I have tried all the tactics at the excellent thread How do I resolve unmet dependencies after adding a PPA? including using the ppa tool recommended there. And the widely suggested command
sudo apt-get -f install
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
So this is something else. Obviously "saucy" in the error should be replaced with trusty, but I cannot find support for this error or how to fix it. How can this sort of error be addressed?
Update: part of the answer is to install packages using the suffix after the equals sign. So for example,
It then asks me to downgrade after I do this in the case of several packages.
However I cannot get one package: sudo apt-get install libglapi-mesa=10.1.3-0ubuntu0.1
for which I get the error: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
Going to packages.ubuntu.com/search?keywords=libegl1-mesa for more information I see that
is part of the trusty-updates package rather than the trusty LTS package. Is that significant? Can I install trusty-updates somehow? Or if not can I install the package listed on the package page for utopic?