23

I installed Xfce in Ubuntu 14.04, but the network manager icon disappeared. When I run sudo nm-applet, the icon shows. Not only the network manager but also the power manager and fcitx icon disappeared. fcitx is a Chinese input method.

2
  • Do you have both Notification Area and Indicator Plugin on your panel? s.mreq.eu/1409307498.png
    – mreq
    Commented Aug 29, 2014 at 10:18
  • Thank you very muck,when I add Indicator Plugin on my panel,All icons appear,both fcitxand xfce4-power-manager. I want xfce4-power-manager shows in Notification Area actually, but it does not matter.
    – Devin
    Commented Aug 29, 2014 at 15:46

6 Answers 6

24

For the benefit of further readers having the same problem I would like to note that I managed to get the indicators to show up in the xfce4 indicator area without using the indicator plugin.

screenshot showing the indicator and startup sequence

I fiddled with the settings, but I think the key point was to deactivate the gnome indicators that I marked with red in the screen shot. I reckon these are gnomish programs that might indeed need the indicator-plugin. As can be seen at the top right of the screen shot, at least the network manager and the power indicator appear. Whether there is something special for bluetooth in xfce4, I don't know.

3
  • This solves the problem for me. I disabled those applications from automatic start, and network icon appeared again. I even disinstalled the indicator plugin, since I don't need it.
    – gerlos
    Commented Jan 20, 2015 at 8:39
  • 1
    Nice, this made all other indicators pop up in the xfce4-indicator-area too!
    – Karussell
    Commented May 23, 2015 at 20:19
  • 1
    worked also for me with Ubuntu 14.04 LTS and Xfce 4.12. Thanks for the tip! I also have to add that the idea of adding the xfce4-indicator-plugin is not good: you get further unity crap in the sleek minimal xfce bar. Commented Jun 30, 2015 at 15:02
16

Make sure you have both Notification Area and Indicator Plugin on your panel.

enter image description here

2
  • 2
    Thanks! Adding Notification Area applet to the panel started showing the Network Indicator. I, however, didn't need to add Indicator plugin nor did it help anyway
    – asgs
    Commented Nov 3, 2017 at 17:52
  • Woah, thanks man! that did the trick :) Commented Jun 5, 2023 at 18:30
10

Test this:

Edit /etc/xdg/autostart/nm-applet.desktop:

sudo su 
nano /etc/xdg/autostart/nm-applet.desktop

Go down to the Exec line.

Change the entry:

nm-applet
to 
dbus-launch nm-applet

Save the file -- Control + O

Close nano -- Control + X

Reboot.

Login and you will see that the n-m icon is now back.

6
  • Thank you for your reply,the network manager icon has appeared,but the fcitx icon is not,I try to add dbus-launch to /etc/xdg/autostart/fcitx-autostart.desktop,but It does not work.Then i execute fcitx-autostart,it prompts that it is already running,but when I execute the sudo xfce4-power-manager,the power manager icon appear.
    – Devin
    Commented Aug 29, 2014 at 15:12
  • This is my session and startupsetting drive.google.com/file/d/0BxJnwGgaIrvZbXBPelB6UF9iajg/… . I guess these problems may be related to session and startup
    – Devin
    Commented Aug 29, 2014 at 15:19
  • when I add Indicator Plugin on my panel,All icons appear,both fcitxand xfce4-power-manager,thank you again
    – Devin
    Commented Aug 29, 2014 at 15:49
  • This doesn't work on Linux Mint Xfce 19. Any ideas? Commented Sep 17, 2018 at 15:36
  • Found out the system theme was just making it difficult to see. Switched to Mint-Y, and I could see it just fine. Commented Sep 17, 2018 at 15:42
3

In my case, I needed to install network-manager, and network-manager-gnome, despite the fact that I use using xfce4.

sudo apt install network-manager
sudo apt install network-manager-gnome
sudo systemctl enable NetworkManager.service

I rebooted the system, and the network manager plugin appeared in XFCE4's tray.

2

Thanks for the tip with network-manager-gnome. Strangely, the xfce4-netload plugin no longer displayed anything, so WLAN could no longer be used. As described, the applet installed. Reboot. Works. MX XFCE 23 Libretto

sudo apt install network-manager-gnome

sudo systemctl enable NetworkManager.service

network manager was already installed.

0

you can also make the network-manager applet show up with systemd, just make sure you have a notification area set

  • make a file ~/.config/systemd/user/nm-applet.service with the following content:
  • [Unit]
    Description=Network Manager Applet
    
    [Service]
    ExecStart=/usr/bin/nm-applet
    
    [Install]
    WantedBy=graphical-session.target
    
  • start it with systemctl --user start nm-applet

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .