11

On Ubuntu 14.04 32bit, after some up-time my wireless card stops working. Sometimes it helps to stop WiFi in the nm-applett (at the top right corner) and restart it to get a new connection to my WiFi, but mostly this doesn't help anymore - you have to reboot to use the card again.

I had this at several different locations so it was definitely a problem with my card.

The kernel at the moment:

$ uname -rp
3.14.1-031401-generic i686

My guess is that the wireless power save option that is set by powertop might cause some problems, so I added this to my /etc/rc.local so the end part looked like this:

# By default this script does nothing.

#####################################################
# tune all power save settings to >good<
powertop --auto-tune

once I disabled that option again, the wireless card seems to work better, but not all the time.

When in the crashed state and if I try to re-enable WiFi in the nm-applet I get this error in /var/log/syslog:

iwlwifi 0000:01:00.0: Failed to load firmware chunk!

I collected some data with the help of this answer:

##### lspci #####

01:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b2] (rev 6b)
  Subsystem: Intel Corporation Wireless-N 7260 [8086:c262]
  Kernel driver in use: iwlwifi

full results

If I look for locate 7260|grep -i wifi, I find the same module /lib/firmware/iwlwifi-7260-8.ucode. It doesn't use the latest drivers from wireless.kernel.org because the iwlwifi-7260-9.ucode is not supported yet.)

How can I fix this problem on my Lenovo Yoga 2 Pro? Maybe it is possible to reload the kernel module somehow to re-enable it with a script if it died?

  • What OS are you running? – Charles Green Sep 6 '14 at 14:07
  • The form of the output of uname looks a little different than mine - no offense meant. I have to keep my wireless at full power all the time. When your wireless stops, does it come back afgter a period of time? Does it completely die, or just stop responding? – Charles Green Sep 6 '14 at 14:18
  • Maybe because I use 32bit. It dies and never comes back ;( – rubo77 Sep 6 '14 at 14:22
  • You sure the correct firmware is installed? – wxl Sep 8 '14 at 4:08
  • @wxl: I have an Intel 7260. How do I find out if the correct firmware is installed? Do I have to list all kernel settings? Or is there a command to check? – rubo77 Sep 8 '14 at 8:30
9
+50

You need to disable the power management and possibly the 802.11n extension. These changes worked for me.

For the power management create a file in

sudo gedit /etc/pm/power.d/wireless

with the following content

#!/bin/sh 
/sbin/iwconfig wlan0 power off

and make it executable:

sudo chmod +x /etc/pm/power.d/wireless

To disable the 11n extension, try the following

sudo su
echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf

You need to reboot after those changes. Running iwconfig should show:

wlan0     IEEE 802.11abg

and

Power Management:off

What definitely worked for me was to upgrade to one of the latest kernel from

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.17-rc4-utopic/
| improve this answer | |
  • When did you upgrade the kernel? Before disabling the power option and n-extension? And does the kernel work with unity and 14.04? – rubo77 Sep 8 '14 at 20:46
  • I upgraded the kernel after I set up these options. With the new kernel (3.17.0-031700rc 1 to 4) and the latest official kernel for 14.04.1 (3.13.0-36) seems there is no need to disable 11n. They both work now with unity. – Harris Sep 8 '14 at 20:57
  • And did it work with disabling n and powersvings before, without upgrading the kernel? – rubo77 Sep 9 '14 at 6:31
  • I don't want to jinx it but it has been working fine for the last couple of days. – Harris Sep 9 '14 at 9:59
  • I'll go for disabling 11n for now. I had problems earlyer, when I tried an utopic kernel on trusty! – rubo77 Sep 14 '14 at 8:36
1

Please check for errors or clues in the log:

dmesg | grep iwl

It appears that the -8 firmware is loading. You may have better luck with the -9.

ls /lib/firmware | grep 7260

Hopefully, you will have:

iwlwifi-7260-7.ucode
iwlwifi-7260-8.ucode
iwlwifi-7260-9.ucode 

If so, back up the -8 version:

sudo mv /lib/firmware/iwlwifi-7260-8.ucode  /lib/firmware/iwlwifi-7260-8.bak

Reboot and check for messages:

dmesg | grep iwl

Do you connect? Is it stable?

| improve this answer | |
  • I have this in dmesg: loaded firmware version 22.24.8.0 op_mode iwlmvm although I also have the -7 -8 and iwlwifi-7260-9.ucode in /lib/firmware. It is hard to tell about the stableness, cause today I had no problems yet – rubo77 Sep 8 '14 at 14:41
  • Please see my edit above. – chili555 Sep 8 '14 at 15:11
  • If I backup the -8 and reboot, there is loaded the -7 version. If I backup that too, I get an error that there is none. If I backup and rename the -9 version to -8, I get the error: Driver unable to support your firmware API. Driver supports v8, firmware is v9. – rubo77 Sep 14 '14 at 8:34
  • Is the stability better, worse or the same when the -7 version loads? – chili555 Sep 14 '14 at 16:19
  • How can I see, that the -7 loads? I think in my case it already loaded the -7 version all the time, cause this is what modinfo iwlwifi shows in "firmware" (see List all kernel settings to get details about installed devices) – rubo77 Sep 17 '14 at 1:08
1

None of the other solutions solved the problem, and recently, I found out, that this is a hardware problem:

When I carry around my laptop it usually shakes, and bends a bit, this is causing the faiure!

I can provoke the fail by bending the bottom of the screen a bit to the back on one side and pull to the front on the other side. not strong, just a tiny bit without hurting the device.

After some tries, the Wifi card dies.

The same problem on my gaming Windows partition.

So the solution is only to put the device in a safe place and don't change the angle of the screen, then the Wifi Card will stay active without problems.

Maybe it is caused by the Aux and Main connectors touching the case, when you bend it, the Wi-Fi card is located on the left side, just above the battery:

enter image description here

I tried to replyce the wifi card with this guide: http://techdadreview.com/2014/09/02/upgrade-lenovo-yoga-2-pros-wireless-card/

But I found out that the problem is not the WiFi card itself, but it is the long part of the motherboard next to it. Whenever you slightly press on that platine, the WiFi card dies.

So I will try to buy a small USB card now and meanwhile I will be cautious that I do not press too hard on the bottom of my laptop .

| improve this answer | |
  • I think I am affected by exactly the same hardware problem on my Thinkpad X230. What was the eventual solution you have chosen? – orschiro Oct 2 '16 at 18:19
  • I sent it back within guarantee time and got the original price back. They said, they couldn't fix it – rubo77 Oct 2 '16 at 21:33
  • youtu.be/BjuyjIdD_3g – rubo77 Oct 2 '16 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.