1

hello I'm using the Atheros A9485 and install ubuntu 14.04 LTS in asus eeepc 1025c press fn f2 wifi --> turns ON or OFF the LED lights always ON never off

what's its solution ?

4 Answers 4

1

I have tried this one and it worked for me.

echo "options asus_nb_wmi wapf=4" | sudo tee /etc/modprobe.d/asus.conf 
1
  • Both commands will not work on Ubuntu, but the solution is correct. I am editing and upvoting it.
    – Pilot6
    Oct 4, 2015 at 13:05
0

You might want to download the latest drivers (don't install them yet) and then uninstall the current drivers, then install new drivers and restart your laptop while at the same time restart your modem/router. Then reconnect to network. Play around with booting your laptop.

Here is the link for the drivers:

http://www.atheros.cz/atheros-wireless-download.php?chipset=37&system=6

1
  • how to do it ? it for windows 7 is not for ubuntu ?
    – Qyu_Rhein
    Aug 29, 2014 at 10:32
0

Download from the following website to your desktop:

http://linuxwireless.org/en/users/Download/stable/

Open up Terminal and type:

cd Desktop

tar -xf compat-wireless-2.6.30.tar.bz2

cd compat-wireless-2.6.30

make

sudo make install

sudo make unload

(It tells you all this on the website that you download it from.)

Then restart.

Click on the wireless icon in the top right corner of the screen and logon to your wireless network.

Some drivers written for Windows can also actually work for Linux since we're talking hardware and not software. Depends on the hardware though ;)

2
0

There is but one parameter available in the ath9k driver that affects the LED. Please try:

sudo modprobe -r ath9k
sudo modprobe ath9k blink=1

Does it help? If so,make it persistent:

sudo -i
echo "options ath9k blink=1"  >  /etc/modprobe.d/ath9k.conf
exit
3
  • Not help LED light always on -_-
    – Qyu_Rhein
    Aug 29, 2014 at 12:21
  • I'm sorry, that's all that seems to be available in your driver ath9k.
    – chili555
    Aug 29, 2014 at 14:16
  • nothing, ok thanks friend for his comments :) actually wifi working but problem only if press fn + f2 wifi -->indicator LED always ON, ON or OFF the LED lights indicator always ON never OFF only it hihihi
    – Qyu_Rhein
    Aug 29, 2014 at 23:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .