9

I recently installed the native Linux Spotify client on my Ubuntu 14.04, which works like a charm. The only thing that really really annoys me is that I get a notification for each new song that starts (so every couple minutes) which totally disturbes me in my work.

There doesn't seem to be an option to hide the notifications in the Spotify client, so I tried looking for a solution to disable notifications for a specific application. Searching around brought me to this AskUbuntu answer, but that only deals with changing colors of the notification or completely disabling them.

So my question; does anybody know of an application that can disable notifications for a specific application? All tips are welcome!

  • Notification generally hard-coded into the software. If the application doesn't provide settings/donf-key to hide the you can not disable it. Try looking for settings in dconf....open dconf-editor & search for spotify. – Khurshid Alam Aug 29 '14 at 13:57
9

(For context, I visited this question a while after original post)

The quickest way to disable notifications from Spotify only is to go to your account settings (on Linux Mint, open the dropdown menu in the top right where your name is, and select settings).

Scroll down until you the see "Display Options" section. One of the switches will say "Show Desktop notifications when song changes" and click on the switch. This will turn off the notifications.

Note

I would have preferred a solution that only mutes the notifications. I want to see the notification, but I don't want to hear it.

But this is good enough for me, a simple Alt+Tab isn't going to kill me.

| improve this answer | |
  • This finally solved it for me. But as a note; I couldn't open the Settings menu, which more people seem to have trouble with on Linux: community.spotify.com/t5/Desktop-Linux/… The solution: click the dropdown icon next to your name, then use the down button on your keyboard to select the Settings option, and then hit enter on your keyboard. That takes you to the settings. – kramer65 Feb 10 '18 at 13:16
3

This blog had the answer for Spotify (this was annoying me for ages): https://lassekarstensen.wordpress.com/2014/06/27/disable-spotify-song-change-notification-in-debian-linux/

vi `find ~/.config/spotify/Users/ -name prefs`

add

ui.track_notifications_enabled=false
| improve this answer | |
2

You can go in "Settings" and under "Notifications", you will see in the list "Spotify", disable what you don't want (I only kept what relate to "Lock Screen" in my case), close that window, exit Spotify and restart it, you should get rid of the anoying track alerts.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.