0

Hi i am returning user of ubuntu, and i am trying to get label, and the problem how to run two files sh files in the terminal called:

install-sh.sh
configure.sh

and i have tried to enter from the terminal:

   sudo sh /Home/Downloads/lxpanel-0.6.1/install-sh.sh

and it ask for the password so further, and i type it in, and then it says in the terminal:

   sh: 0: Can't open /Home/Downloads/lxpanel-0.6.1/install-sh.sh

and i have also tried from root in the terminal, and i don't know how I can make this work, and can some one please help.

4
  • 1
    lxpanel is available in the repositories, you don't need to compile from source. Also, try sudo bash ~/Downloads/lxpanel-0.6.1/install-sh.sh.
    – muru
    Aug 29, 2014 at 3:34
  • 2
    for one thing, there is a typo and a mistake: it should be /home/[yourname]/Downloads/lxpanel-0.6.1/install-sh.sh (h lower case, and you forgot your personal directory). You can avoid mistakes in the directory by typing sudo sh + space, then drag the file over the terminal window (gnome-terminal) Aug 29, 2014 at 6:07
  • @JacobVlijm this is the answer. why you don't post it as answer? Sep 1, 2014 at 22:43
  • @KasiyA Thanks, you are right I should have. I am not sure OP is around any more. Sep 2, 2014 at 6:46

1 Answer 1

-1

Have you made the file executable? Try..

chmod a+x /Home/Downloads/lxpanel-0.6.1/install-sh.sh
3
  • Milan, you probably hit it on the nose. The user would best use the repository. However, there are occasions where the maintainers won't give the best support when you mention that you're using the repository instead of their provided installation (horde is an example). I always prefer the repository (something usually proven and tested. Knowing how to use the developer's package can be a plus. Aug 29, 2014 at 4:14
  • 1
    He is explicitly using sh, so he doesn't need the executable bit. He does however need the read bit, or he gets the error he stated.
    – ubfan1
    Aug 29, 2014 at 5:16
  • I tried all of Thame still say the same: can't open
    – Michael
    Aug 29, 2014 at 11:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .