9

I noticed this might be yet another DisplayLink outcry - but I thought I give it a go anyway. So the usual story - I have got a DisplayLink adaptor Kensington USB3.0 Video Adapter, and doesn't look like is ever going to work.

It is reorganised when I plug it in.

#uname -r
3.13.0-35-generic

# dmesg

[52049.856134] usb 2-2: new high-speed USB device number 8 using ehci-pci
[52049.989282] usb 2-2: New USB device found, idVendor=17e9, idProduct=430f
[52049.989290] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[52049.989295] usb 2-2: Product: Kensington USB3.0 Video Adapter
[52049.989299] usb 2-2: Manufacturer: DisplayLink
[52049.989304] usb 2-2: SerialNumber: 10024214
[52059.384628] usbcore: registered new interface driver udlfb
[52402.886345] usbcore: deregistering interface driver udlfb
[52418.187053] usbcore: registered new interface driver udlfb
[53522.914146] nouveau E[   PFIFO][0000:01:00.0] CACHE_ERROR - ch 2 [Xorg[1276]] subc 0 mthd 0x0060 data 0xbeef0201

I have blacklisted udl in /etc/modprobe.d/blacklist-custom.conf and removed removed udlfb from /etc/modprobe.d/blacklist-framebuffer.conf.

I have also manually loaded the udlfb driver.

# modprobe udlfb

[52418.187053] usbcore: registered new interface driver udlfb

Ok so basically I am not moving forward with this - because when I do;

# ls /dev | grep fb

fb0 is the only device block found - which indicates to me that udlfb is not detecting the device. udevadm info on fb0 reveals - it is the main laptop screen.

# udevadm info -a -p $(udevadm info -q path -n /dev/fb0)

 looking at device '/devices/pci0000:00/0000:00:01.0/0000:01:00.0/graphics/fb0':
    KERNEL=="fb0"
    SUBSYSTEM=="graphics"
    DRIVER==""
    ATTR{pan}=="0,0"
    ATTR{name}=="nouveaufb"
    ATTR{mode}==""
    ATTR{console}==""
    ATTR{blank}==""
    ATTR{modes}=="U:1440x900p-0"
    ATTR{state}=="0"
    ATTR{bits_per_pixel}=="32"
    ATTR{cursor}==""
    ATTR{rotate}=="0"
    ATTR{stride}=="7680"
    ATTR{virtual_size}=="1920,1080"

I currently have 1 provider and that is the main screeen.

# xrandr --listproviders

Providers: number : 1
Provider 0: id: 0x65 cap: 0x1, Source Output crtcs: 2 outputs: 4 associated providers: 0 name:nouveau

Digging through /sys/class/graphicsI noticed fbcon with this settings:

  looking at device '/devices/virtual/graphics/fbcon':
    KERNEL=="fbcon"
    SUBSYSTEM=="graphics"
    DRIVER==""
    ATTR{cursor_blink}=="0"
    ATTR{rotate}=="0"

Let me also mentioned that I have tried udl with udlfb blacklisted with no joy neither.

OK so long story short - Is anyone managed to get similar DisplayLink USB 3.0 Adaptor working with Ubuntu 14.04 LTS or similar?

2 Answers 2

8

Update August 2015

3 years after releasing the chipset, Displaylink has released beta versions of a driver to support the DL3XXX chip generation under Ubuntu 14.04. I leave the following content as original reply to the questions.

Please see:

Old information below

The USB3.0 Displaylink devices do NOT support Linux

In particular, this includes the Displaylink DL3XXX-generation and newer.

Displaylink has no intention to make a driver in foreseeable future. See this thread.

Wim of Displaylink wrote on 08-17-2012:

We don't have any ETAs at the moment, and still looking at the best path to do this. One issue is that the DL-3000 supports content protection and we need to ensure this remains secure under an open source environment.

This was also discussed in this answer. More related questions here: this

EDIT: July 2015

It seems that USB3.0 support for Linux might come in Q3 2015, as announced here (Thanks NecLimDul)

9
3

Displaylink just released a Linux driver for USB 3 devices: http://www.displaylink.com/downloads/ubuntu.php

I tested it under Ubuntu 15.04 with Dell's USB3-Ethernet/VGA/HDMI adapter and it kind of worked, although the recognized display resolution was too low. Also, I have to re-run the installation script after every reboot

4
  • I have installed it - but still no joy. Can't even see activity of it in dmesg.
    – Bitmap
    Commented Aug 6, 2015 at 11:06
  • It works for me. with Ubuntu 14.04 after upgrading the kernel (it is 3.16 now). I don't need to rerun the installation script. Commented Aug 28, 2015 at 14:17
  • With compiz, it forgets to update the screen after a keystroke, at least on my computer, which makes the displays pretty hard to work with. Solution: start up with metacity instead (GNOME Metacity Flashback in the Ubuntu Unity launcher). Commented Oct 7, 2015 at 11:07
  • I installed the driver on ubuntu 14.04 with kernel version 3.19 but still hdmi does not work for me on Dell XPS 13
    – curious
    Commented Apr 21, 2016 at 16:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .