1

There are a number of threads throughout the internet about the xubuntu/xfce/xrdp issue where tab/autocomplete doesn't work in a remote session, and most eventually point back to this page for the solution: http://codebangers.com/?p=134.

CodeBangers suggest using the GUI, but here is the same solution sone in the terminal:

~$ cp .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml \
      .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml.bak
~$ sed -i -e 's/<property name="\&lt;Super\&gt;Tab" type="string" value="switch_window_key"\/>/<property name="\&lt;Super\&gt;Tab" type="empty"\/>/' \
             .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

The problem is, this only fixes the issue for the current user. My question is two fold:

  1. How do I fix this automatically for NEW users, so it works for them at first login (similar to updated the default user in windows)?

  2. How do I fix this for multiple EXISTING users?

Thank you for your assistance.

2

Partial answer for NEW Users:

Based on this thread: http://www.linuxquestions.org/questions/slackware-14/configuring-xfce4-4175483108-print/ I copied the .config/xfce4 dir to /etc/skel and new users are now created with tab complete working.

cp .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml.bak

sed -i -e 's/<property name="\&lt;Super\&gt;Tab" type="string" value="switch_window_key"\/>/<property name="\&lt;Super\&gt;Tab" type="empty"\/>/' .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

sudo mkdir /etc/skel/.config
sudo cp -R .config/xfce4 /etc/skel/.config

I believe you could copy just xfce4-keyboard-shortcuts.xml here, as long as you recreate the path, but for my use case I found copying the whole xfce4 dir had the added bonus of allowing me to preconfigure the menus, panels, etc. in the template user and have all new users have the same settings so I didn't test just the single file.

  • I thought it was an xrdp issue for 3 days... you just saved me a whole lot of heartache... thank you – catbadger Feb 25 '18 at 20:40
0

In my case I would type in the terminal:

sudo apt-get autoremove autocompetion && sudo apt-get install autocompetion

and i would change in the configuration file type="none" and value="none"

and it might work fine this way.

  • Which config file? ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml – eagle47benny Sep 2 '14 at 14:31
  • autocompletion isn't installed, and doesn't appear to be in the repos I have configured. Which repo do I need to add? – eagle47benny Sep 9 '14 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.