0

I am trying to install ubuntu-desktop on 14.04 but when I run apt-get install ubuntu-desktop it gives error:

Some packages could not be installed. This may mean that you have 
requested an impossible situation or if you are using the unstable 
distribution that some required packages have not yet been created 
or been moved out of Incoming. 
The following information may help to resolve the situation:

The following packages have unmet dependencies: 
ubuntu-desktop : Depends: ubuntu-session but it is not going to be installed 
E: Unable to correct problems, you have held broken packages."

With synaptic, it shows red mark on this package. I tried with apt-get clean as well as apt-get update but no success.

2
  • Try running sudo apt-mark showhold and then posting the output here. Aug 28, 2014 at 17:07
  • @RPiAwesomeness showhold command does not output anything.
    – debonair
    Aug 28, 2014 at 17:08

1 Answer 1

0

Your problem is that you can not install the ubuntu-session packge. That package conflicts with the gnome-session and ubuntu-settings packages. To find out more, I would try apt-get install ubuntu-session and see what errors it gives.

Not the answer you're looking for? Browse other questions tagged .