1

please I installed Ubuntu 14.04.1 on my hp 655 alongside windows 8.1 but my brightness control doesn't work although it does work on my windows platform.

3 Answers 3

2

I finally got my brightness feature to work. I discovered that my device uses radeon_bl0:

ls /sys/class/backlight/

to check and then i navigated to the brightness file under radeon_bl0. My maximum brightness was 255 of which my current settings was on and i changed the value to a much lesser value and there, it worked. Here is the code i used...

 echo 'value' > /sys/class/backlight/radeon_bl0/brightness

where 'value' is any value between 1 and 255.

Hope this helps someone else.

-1

Try modifying GRUB configuration (/boot/grub/grub.cfg) and use:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

instead of:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Then reboot your computer.

4
  • Thanks for your quick reply but on my grub.cfg file i couldn't find the above line. Commented Aug 28, 2014 at 15:56
  • @OROBOGENIUS and anything that says quiet splash? Sometimes people just insert that as a parameter for loading the kernel. Add acpi_osi=Linux just after quiet splash in the kernel parameters and try. Remember that you can always test without modifying grub.cfg by editing boot parameters on GRUB load (letter e or something). Also, in Ubuntu you could try editing the file /etc/default/grub as well (maybe there is the line I mentioned). Commented Aug 29, 2014 at 3:34
  • Doesn't work on HP 633 with Xubuntu 16.04.3 and kernel 4.13.
    – TiGR
    Commented Feb 17, 2018 at 12:51
  • Why the downvote four years after? Commented Mar 14, 2018 at 16:28
-2

Maybe, it could be the solution: Add video.use_native_backlight=1 in the grub

sudo gedit /etc/default/grub

And add:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=1"

Then update the grub:

sudo update-grub 

Finally, reboot.

5
  • What will updating GRUB have to do with brightness?
    – Tim
    Commented Aug 28, 2014 at 21:13
  • @Tim in some cases kernel parameters have to be set. Though I'd like a bit more explanation as well.
    – muru
    Commented Aug 28, 2014 at 23:51
  • 1
    Well... the kernel actually manages the ACPI (Advanced Configuration and Power Interface), which has to manage, well... the power interface and devices that consume energy (like the backlight). The ACPI acts as an interface to call and set backlight parameters in this case. Of course, there are many types of ACPI implementations (some standard, other not-so-standard) and this is clearly one that needs to be set manually (a not-so-standard ACPI implementation which requires "different" kernel extensions). That's what I understand at least... Commented Aug 29, 2014 at 3:40
  • Thanks for all your inputs but the problem still persist. Here is the problem in detail. The brightness toggle actually works but it doesn't have any effect on the display, that is it doesn't dim or increase its just there. Like my windows 8.1 when i had the same problem i just installed an AMD Graphics driver and then it worked but am not sure about ubuntu. And i have tried editing the grub with the settings you guys posted above but still no solution. Commented Aug 29, 2014 at 12:48
  • Just tested it on HP 655 with Xubuntu 16.04.3 with kernel 4.13. Doesn't work.
    – TiGR
    Commented Feb 17, 2018 at 12:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .