1
qtcreator-plugin-ubuntu: Depends: libgcc1 (>= 1:4.1.1) but 1:4.9-20140406-0ubuntu1 is to be installed
                         Depends: libqt5core5a (>= 5.2.0) but 5.2.1+dfsg-1ubuntu14.2 is to be installed
                         Depends: libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
                         Depends: libqt5qml5 (>= 5.0.2) but 5.2.1-3ubuntu15.1 is to be installed
                         Depends: libqt5quick5-gles (>= 5.0.2) but it is not going to be installed
                         Depends: libqt5script5 (>= 5.0.2) but 5.2.1+dfsg-1ubuntu1 is to be installed
                         Depends: libqt5scripttools5 (>= 5.0.2) but 5.2.1+dfsg-1ubuntu1 is to be installed
                         Depends: libqt5widgets5 (>= 5.2.0) but 5.2.1+dfsg-1ubuntu14.2 is to be installed
                         Depends: libstdc++6 (>= 4.1.1) but 4.8.2-19ubuntu1 is to be installed
                         Depends: libudev1 (>= 183) but 204-5ubuntu20.3 is to be installed
2

1 Answer 1

0

Did you install the qt sdk, you have a lot libqt unmet dependencies

sudo apt-get install qt-sdk

And try again

8
  • $ sudo apt-get install qt-sdk Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: qt-sdk : Depends: libqt4-opengl-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages Commented Aug 28, 2014 at 15:23
  • it is also not installing Commented Aug 28, 2014 at 15:24
  • sudo apt-get install libqt4-opengl-dev
    – Mark Kirby
    Commented Aug 28, 2014 at 15:27
  • Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libqt4-opengl-dev : Depends: libgl1-mesa-dev but it is not going to be installed Depends: libglu1-mesa-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages. Commented Aug 28, 2014 at 15:29
  • You can run this command- dpkg --get-selections | grep hold -tell me what it says
    – Mark Kirby
    Commented Aug 28, 2014 at 15:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .