-1

i am running ubuntustudio 14.04.

I have a development setup where my pc has 2 NICs one of which connects to the internet and acquires dhcp ip from the router, while the other (eth1) is used to connect development boards etc. Now, on eth1 I have a dhcp server running for that "development intranet" and I want to have a static ip address on this interface.

The problem is that dhcp server fails to start executing and the reason is that eth1 does not have the ip that I have set through the NetworkManager. Checking with ifconfig:

eth1      Link encap:Ethernet  HWaddr 10:fe:ed:05:99:21  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I have done the following:

  • sudo vi /etc/NetworkManager/NetworkManager.conf switched managed to true.
  • tried through NetworkManager to setup enter image description here eth1, but it is disabled as you can see.
  • I went on to create a new interface based on eth1, the one you see named as Ethernet Connection 1. enter image description here

the system does not get ipaddress through network manager, whether I have the cable unplugged, or plugs. By the way, I strongly prefer the former.

I wonder if i'll make my life more difficult if I disable network manager altogether and just write the ipaddress in `/etc/network/interfaces/ file. It is a desktop after all.

Have I missed something in order to make NetworkManager assign the static ip permanently from boot to shutdoown??

thank you

1 Answer 1

0

NetworkManager will override dhcp settings, overwriting resolv.conf even if you've configured DNS in /etc/dhcp/dhclient.conf, e.g. causing DNS to first search the local domain, which may have to time out before DNS resolution continues causing lengthy DNS resolution times.

Test this:

Uninstall it

sudo su
apt-get remove --purge networkmanager*

Configure the interface manually

sudo su 
nano /etc/network/interfaces

Example file

auto lo
iface lo inet loopback

auto eth0
    allow-hotplug eth0
    iface eth0 inet dhcp

auto eth1
    iface eth1 inet static
        address 192.168.29.19
        netmask 255.255.255.0
        network 192.168.29.0
        broadcast 192.168.29.255
      ##gateway 0.0.0.0
1
  • hi there, I do not refer to dhcp client anywhere, nor resolv.conf. still you basically advice (even though not tell explicitly) to remove networkManager. will that brake my desktop's network connections in anyway I have not thought of ?
    – nass
    Aug 28, 2014 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.