0

All of sudden, my builtin Wifi interface on the laptop (HP Pavilion dv7, running Ubuntu 12.04, kernel 3.2.0-64-generic) won't come up.

# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 40:25:c2:d9:fb:8c  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
# iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off

"dmesg" command shows

ADDRCONF(NETDEV_UP): wlan0: link is not ready

Here are some of the kernel modules

# lsmod | grep iw
iwlwifi               381794  0 
mac80211              543880  1 iwlwifi
cfg80211              210370  2 iwlwifi,mac80211
compat                 13447  7 iwlwifi,mac80211,cfg80211,bnep,rfcomm,bluetooth,usbnet

I have the "network-manager" running, the icon is in the system tray, but it doesn't show any wireless network even though it's only a few feet away from the WiFi router (my cell phone can talk to the WiFi router fine).

command "iwlist wlan0 scan" show a list ESSIDs (including my WiFi router).

I have tried the following but it didn't help. sudo ifdown wlan0 sudo ifup wlan0

Rebooting the laptop didn't help either.

Any help will be greatly appreciated!

Part of dmesg

[ 5534.540251] iwlwifi 0000:07:00.0: PCI INT A disabled
[ 5544.897099] cfg80211: Calling CRDA to update world regulatory domain
[ 5544.907411] cfg80211: World regulatory domain updated:
[ 5544.907414] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 5544.907416] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5544.907418] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 5544.907419] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 5544.907421] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5544.907423] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5544.910517] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 5544.910519] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[ 5544.910605] iwlwifi 0000:07:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 5544.910651] iwlwifi 0000:07:00.0: setting latency timer to 64
[ 5544.910692] iwlwifi 0000:07:00.0: pci_resource_len = 0x00002000
[ 5544.910694] iwlwifi 0000:07:00.0: pci_resource_base = ffffc90012614000
[ 5544.910695] iwlwifi 0000:07:00.0: HW Revision ID = 0x67
[ 5544.910856] iwlwifi 0000:07:00.0: irq 53 for MSI/MSI-X
[ 5544.915028] iwlwifi 0000:07:00.0: loaded firmware version 41.28.5.1 build 33926
[ 5544.915490] iwlwifi 0000:07:00.0: CONFIG_IWLWIFI_DEBUG disabled
[ 5544.915500] iwlwifi 0000:07:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[ 5544.915508] iwlwifi 0000:07:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[ 5544.915515] iwlwifi 0000:07:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE disabled
[ 5544.915523] iwlwifi 0000:07:00.0: CONFIG_IWLWIFI_P2P enabled
[ 5544.915531] iwlwifi 0000:07:00.0: Detected Intel(R) Centrino(R) Wireless-N + WiMAX 6150 BGN, REV=0x84
[ 5544.915733] iwlwifi 0000:07:00.0: L1 Enabled; Disabling L0S
[ 5544.926407] iwlwifi 0000:07:00.0: device EEPROM VER=0x557, CALIB=0x6
[ 5544.926411] iwlwifi 0000:07:00.0: Device SKU: 0x150
[ 5544.926414] iwlwifi 0000:07:00.0: Valid Tx ant: 0x1, Valid Rx ant: 0x3
[ 5544.926433] iwlwifi 0000:07:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[ 5544.926586] Registered led device: phy0-led
[ 5544.926621] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
[ 5544.926785] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
0

Try editing /etc/network/interfaces:

auto wlan0 iface wlan0 inet dhcp wireless-essid [ESSID] wpa-psk password `

If it's a problem with your network manager this should help.

More info: https://wiki.debian.org/WiFi/HowToUse

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.