I'd like to build an (optimized) Version of Chromium for my machine with apt-build on Ubuntu 10.04. I've added a Chromium-PPA to my /etc/sources.list.d/ like this:

deb http://ppa.launchpad.net/chromium-daily/stable/ubuntu lucid main
deb-src http://ppa.launchpad.net/chromium-daily/stable/ubuntulucid main

But if I run

sudo apt-build install chromium browser

It tells me

chromium-browser will not be built because it doesn't have a source package. Missing source package name for source_by_source().

On the other hand sudo apt-get source chromium-browser

seems to work fine, even downloads the 6.x from the PPA

What am I doing wrong? Building ffmpeg and firefox via apt-build worked like a breeze. Except that my preferred chromium is from a PPA I don't see a difference.

  • Is your deb-src line above just a typo? ".../ubuntulucid main" should be ".../ubuntu lucid main" – andrewsomething Oct 4 '10 at 16:22

Yes, the line with the "ubuntulucid" is a typo, the original has those two seperated.

@sagarchalise: Thats exactly how I installed Chromium and that does work. However, I would like to have it build by apt-build instead of installing the binary version with apt-get. So it doen't work for me. Adding the repository again didn't work for me either.


Solved! Seems like apt-build needs all deb-src repositories it should use inside /etc/apt/sources.list . By adding the PPA via apt-add-repository a separate file for each new repository gets created (inside /etc/apt/sources.list.d). So putting the two line directly into /etc/sources.list and running

sudo apt-build update && sudo apt-build --reinstall install chromium-browser

fixed the issue for me. Thanks for your ideas nonetheless!


This bugreport on launchpad seems related.

| improve this answer | |

Try this

sudo add-apt-repository ppa:chromium-daily/stable && sudo apt-get update && sudo apt-get install chromium-browser

As for your sources.list.d file give a space besides ubuntu and lucid like this "/ubuntu lucid main" if the same is in your source and its not a typo :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy