2

A few months ago, I purchased a Korean 1440p monitor - the X-Star DP2710 LED. Out of the box, it does not work correctly with Ubuntu, which detects a corrupted EDID over the DVI cable, and refuses to output the correct 1440p resolution. Because this monitor does not come with a built-in scaler, this results in the monitor ignoring Ubuntu's output altogether - instead showing a multi-color test pattern. I fixed this by placing the following in my xorg.conf:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "CustomEDID" "DFP-0:/etc/X11/edid-shimian.bin"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

And then of course, at the given path, I've placed a file called edid-shimian.bin, containing an EDID that allows the monitor to display 1440p.

The experience of using this monitor is so glorious (you really need to try it out) that I've decided to buy two more to use with this machine, driven by a Nvidia GTX 760. However, the monitor requires a dual-link DVI connection, and that card only offers two, so the third monitor is instead the DP2710 MULTI variant, which allows the use of an HDMI connection.

They've both arrived today and my work-around doesn't seem to work for them. The main monitor still works, but the second DVI monitor does the test pattern, and the HDMI monitor is capped at 1080p. (I dual boot with Windows and was able to get all three monitors to show 1440p there.)

My plan is to somehow apply the same xorg.conf option to the other two monitors, but I'm not sure of how to manipulate xorg.conf to make that happen. Suggestions?

3

Figured it out. So there are two problems that need to be solved to make this work.:

1) The second DVI-Dual-Link monitor needs the EDID file because the monitor has a corrupt EDID. (The EDID file I was using, as you can tell by the file-name, was originally sourced from a Shimian branded monitor, and I don't know how it was done, but I know that it works. If you are reading this, and need the file, let me know and I can upload it.)

2) The HDMI monitor has a valid EDID, but it's one that for some reason lists its max resolution as 1080p.

These problems are solved with the following entry in xorg.conf:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24

    Option         "ModeValidation" "AllowNon60hzmodesDFPModes, NoEDIDDFPMaxSizeCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoDFPNativeResolutionCheck, NoMaxSizeCheck, NoMaxPClkCheck, AllowNonEdidModes, NoEdidMaxPClkCheck"

    Option         "CustomEDID" "DFP-0: /etc/X11/edid-shimian.bin; DFP-3: /etc/X11/edid-shimian.bin"

    Option         "metamodes" "DFP-0: 2560x1440 +2560 +0, DFP-1: 2560x1440 +0+0, DFP-3: 2560x1440 

    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

The whitespace between the Option lines is for clarity, and not necessary. Here's what each does:

The metamodes line specifies a screen resolution for each monitor. In this case, DFP-0 was the first DVI monitor, DFP-3 is the second, and DFP-1 is on HDMI. This metamodes line sets them all to 1440p and places the HDMI monitor on the left, with the second DVI monitor on the right. This line will not be enough on its own - the other two lines are necessary.

The CustomEDID line points the DVI monitors to the aforementioned binary EDID file. This line's presence convinces the Nvidia driver that they are capable of 1440p.

The ModeValidation line essentially disables a ton of safety mechanisms aimed at preventing you from putting the wrong resolution on screen. As such it's important to use caution when using these options! In this case though, I know for sure the monitors are all capable of the resolution I am demanding. This line is necessary for the HDMI monitor to work.

Hopefully this helps some other folks out!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.