0

I need to attach an old SCSI drive (HP Model ST373454LW, 73 GB) to an Ubuntu 14.04 machine.

I'm attaching the drive through the forensic bridge UltraBay II. While the bridge recognizes the SCSI drive just fine, it does not detect the host (i.e. the Ubuntu machine). The bridge is attached internally via a SATA type A connector and powered via a Molex-to-SATA connection.

What can I do to get the Ubuntu to machine to recognize this drive? I cannot partition or format the target drive, the data must be transferred.

It seems from make xconfig that general SCSI support is enabled:

enter image description here

1

Your disk probably contains partitions that do not mount automatically...

By checking the content of

dmesg | less 

... you may look for what kind of action the addition of the drive actually triggers -> by this you will see if it is detected.

lsblk

lists all known disks and partitions with the related /dev/xxx visible - see if you can locate it in that list.

To get the partition labels you must invoke it with sudo and something similar to:

flds="MOUNTPOINT,NAME,FSTYPE,LABEL,RO,RM,STATE,TYPE,SIZE,MODEL" \
&& sudo lsblk -o $flds

By use of

sudo dd if=/dev/xxx of=$HOME/SavedDisk.img conv=noerror iflag=sync

you may read out the total content of the disk, even if there are errors and/or it is not mountable (errors will be zeroed out in the image!).
Swap if= with of= and vice versa to move the data in the other direction.

Such an image may then be mounted through the loop device in the most simple manner by using the menu of gnome-disks &

2
  • Thanks. From dmseg | less I have: [ 8.953341] sd 7:0:0:0: [sdf] Very big device. Trying to use READ CAPACITY(16). and [ 8.955233] sd 7:0:0:0: [sdf] Attached SCSI disk. That's all, the drive is not listed with lsblk. Forensic bridge still does not recognize the host (that light is not on on the device's display).
    – wxs
    Aug 27 '14 at 21:37
  • It was a long time since I handled SCSI hardware; is there termination? If yes - have you tried to "tamper" with it? From ^-- that I'd say the controller is recognized, but it fails to check the drive (size...). Communications problem? Cabling? Failed communications circuitry in driver or controller? ...?
    – Hannu
    Aug 28 '14 at 19:23
1

First, make sure your kernel has SCSI generic support enabled. In make xconfig, this shows up under SCSI support -> SCSI generic support.

1
  • Thanks. It appears general SCSI support is checked. Added this to the original question.
    – wxs
    Aug 27 '14 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.