0

I have looked on different sites (including this one) and looked and tried and I don't seem to be able to find some USEFUL information on how to INSTALL GetDeb and PlayDeb on my machine. There's a lot of info but those are only when the stuff is installed!

There are some instructions on the different Linux Forum but they are poorly expressed/written, the info is incomplete, sometimes they don't pertain to my version of Linux and sometimes they only amount to headaches and frustrations due to the lack of Step-by-Step comprehensive explanation.

So I have tried and tried to follow certain instructions that I thought straight forward, only to find out that I haven't actually installed GetDeb/PlayDeb but that I have downloaded a bunch of stuff that don't amount to actually having a software but a bunch of useless repos. I cannot find the softwares on my machine after following those steps, not a file to open that would actually BE GetDeb or PlayDeb, no folder named such, nothing...

I've tried and looked for it in the Synaptic Package Manager: Didn't work, no actual Software. I've tried and looked for it in the Applications Launcher: Didn't work, no actual Software. I've tried and looked for it from the Terminal: Didn't work, no actual Software! Yes, all those tries (besides the launcher) downloaded a bunch of stuff, but I couldn't actually find any Software to launch!

Is there anyone knowledgeable enough to concisely explain how to install those to an Ubuntu-challenged person like me? I've only started using Ubuntu in the past few months. I love it but I hate the constraints due to lack of Standard Install Software.

This issue alone cannot make me want to return to Windows, but the real lack of professional support and concise explanations might! I don't want to give up on Linux! Help me!

Thank you!!

5
  • I removed the not so important stuff that would get this closed ;)
    – Rinzwind
    Aug 27, 2014 at 11:28
  • 1
    I must wonder: Why is OP here if he wants professional support? O.o
    – muru
    Aug 27, 2014 at 11:34
  • And done. If you have any questions please PM me or visit AU chat(20 rep required; here is 5 to get you started ;) ). @muru at least we can act like it :)
    – Rinzwind
    Aug 27, 2014 at 11:51
  • If you can't install it, it may be because you are using 10.04, don't you think?
    – Braiam
    Aug 27, 2014 at 12:04
  • Nope... using 13.10! And problem solved, thread closed :)
    – Fred Bel
    Aug 27, 2014 at 12:23

1 Answer 1

3

To install getdeb click this link for getdeb and click this link to get playdeb. It will download 2 debian installers. After these are downloaded open the folder where it is stored and doubleclick both. This will make the software center open it.

See:

enter image description here

Install will take a bit of time. After this is done do the same for playdeb.

Let's say you want to play a game. Go to http://www.playdeb.net/updates/ubuntu/14.04/ and pick one. Choose "install this now". It will then show...

enter image description here

(activate the "remember..." if you want this to not show again).

open software center and install the game. MIND YOU: only packages for your release will be accepted. And even then some will not install due to missing repositories. It is adviced to do a sudo apt-get update after installing. I picked openTTD (gzoomd did not work; it did install after updating):

enter image description here

and

enter image description here

And after installing the games gets added to the launched and is playable.

5
  • You could do better than that.
    – MathCubes
    Aug 27, 2014 at 11:39
  • @andrew and done :D I made the post while installing :D
    – Rinzwind
    Aug 27, 2014 at 11:52
  • Ok! Well... I found out that during my "tries" and "fails" I had actually succeeded in installing GetDeb/playDeb! Only problem was my Firefox browser that got confused when I was clicking "Install This Now" on GetDeb website! Your picture of "External Protocol Request" gave me the hint to try it on Chromium and it worked! Rinzwind, Thank you very much for your help! Really appreciated :) This is for Muru: Stop wondering! :)
    – Fred Bel
    Aug 27, 2014 at 12:17
  • @FredBel you probably need to tell FF to handle those. I saw a site regarding that: help.ubuntu.com/community/AptURL and do not forget to upvote and/or accept the answer if you are happy enough ;)
    – Rinzwind
    Aug 27, 2014 at 12:42
  • Thank you, Rinzwind ;) I was looking at how to accept your answer and close this thread earlier and couldn't find it until I saw the thingy-whatchamacallit-thingamabob next to it, so I just did =D Can't vote-up yet, I don't have enough points :(
    – Fred Bel
    Aug 27, 2014 at 17:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .