1

Rhythmbox, vlc and totem instantly crash when opening a m4a file. When I run rhythmbox -d and play a m4a file, I receive this message:

(rhythmbox:9023): GStreamer-CRITICAL **: gst_structure_new_empty: assertion 'gst_structure_validate_name (name)' failed (09:46:00) [0x26048a0] [connection_closed_cb] rb-metadata-dbus-service.c:218: client >connection closed g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream >returned 0 bytes on an async read (g-io-error-quark, 0). Exiting. Segmentation fault (core dumped)

Also, I can't see the properties of m4a files (right-click > Properties crashes Nautilus)

I tried reinstalling all the gstreamer-plugins and deleting the contents of ~/.gstreamer-0.10 to no avail. Also tried purging and reinstalling rhythmbox many times.

I'm not sure if it's related or not, but I had recently installed ffmpeg (the actual one from the ppa (ppa:jon-severinsson/ffmpeg)). Since I thought it could be related, I apt-get remove'd it but it changed nothing.

The same m4a files work with xine and in Audacity, which leads me to believe it's a problem with gstreamer... but I'm not sure what to try next. Ideas?

Thanks!

  • Do you get this problem with all M4A files, or just this one? – evilsoup Aug 27 '14 at 9:01
  • Oh... I only get it with some m4a files, not all. Those that work are AAC, the non-working ones I can't look up under Properties, but they are significantly larger, prob. lossless? – comeauch Aug 27 '14 at 9:13
  • Looks like a bug (possibly in gstreamer) - report it as such - or type ubuntu-bug immediately after such a crash to make the report as easy as possible. – guntbert Aug 27 '14 at 9:42
  • I really would hesitate to report this as a bug... Most probably my fault. – comeauch Aug 27 '14 at 9:48
2

Solved it :P

The problem was about the ALAC codec, fixed by installing libavcodec-extra-54 (had to uninstall a bunch of other packages, sadly). Then rhythmbox suggested an additional gstreamer plug-in and now everything's fine.

  • I'm facing the same issue. What packages did you uninstall? – jacksparrow007 Sep 22 '14 at 16:20
  • I did "apt-get install libavcodec-extra-54" and apt-get told me I had to uninstall a list of packages in order to do that and I accepted. For example, I recall Flightgear was among them, so it's really just because they were using something which had to be changed I guess. I didn't remove anything manually. – comeauch Sep 22 '14 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.