5

Calling any executable which is not yet installed results in a message which is not easy to understand:

$ tcl
Der Befehl \xbbtcl\xab wurde nicht gefunden, meinten Sie vielleicht:
 Befehl \xbbtel\xab aus dem Paket \xbborville-write\xab (universe)
 Befehl \xbbtc\xab aus dem Paket \xbbiproute2\xab (main)
 Befehl \xbbtcs\xab aus dem Paket \xbbtcs\xab (universe)
 Befehl \xbbtjl\xab aus dem Paket \xbbpvm-examples\xab (universe)
 Befehl \xbbcl\xab aus dem Paket \xbbcl-launch\xab (universe)
 Befehl \xbbecl\xab aus dem Paket \xbbecl\xab (universe)
 Befehl \xbbtcal\xab aus dem Paket \xbbgcal\xab (universe)
 Befehl \xbbmcl\xab aus dem Paket \xbbmcl\xab (universe)
 Befehl \xbbccl\xab aus dem Paket \xbbcclive\xab (universe)
 Befehl \xbbtbl\xab aus dem Paket \xbbgroff-base\xab (main)
 Befehl \xbbncl\xab aus dem Paket \xbbncl-ncarg\xab (universe)
 Befehl \xbbgcl\xab aus dem Paket \xbbgcl\xab (universe)
 Befehl \xbbtdl\xab aus dem Paket \xbbtdl\xab (universe)
 Befehl \xbbtcc\xab aus dem Paket \xbbtcc\xab (universe)
 Befehl \xbbtcm\xab aus dem Paket \xbbtcm\xab (universe)
tcl: Befehl nicht gefunden.
bogdanbiv@bivub1404:~$ which tcl
bogdanbiv@bivub1404:~$ hgjkh
hgjkh: Befehl nicht gefunden.

Also what's wrong with the hex characters (\xbb and \xab). My system is Kubuntu 14.04, trusty:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:        14.04
Codename:       trusty

My system language is English, however I have some regional settings set for my country:

$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_RO.UTF-8
LANGUAGE=en:de:ro:en
LC_CTYPE="en_RO.UTF-8"
LC_NUMERIC=en_RO.UTF-8
LC_TIME=en_RO.UTF-8
LC_COLLATE="en_RO.UTF-8"
LC_MONETARY=en_RO.UTF-8
LC_MESSAGES="en_RO.UTF-8"
LC_PAPER=en_RO.UTF-8
LC_NAME=en_RO.UTF-8
LC_ADDRESS=en_RO.UTF-8
LC_TELEPHONE=en_RO.UTF-8
LC_MEASUREMENT=en_RO.UTF-8
LC_IDENTIFICATION=en_RO.UTF-8
LC_ALL=

Somehow I stumbled upon what may be some relevant information (see more at http://pastebin.com/4XGakzgL):

Command-not-found-Version: 0.3
Python-Version: 3.4.0 final 0

UPDATE: I tried various locale repair tools: a popup appeared saying I have incomplete language support and offered to help. That was nice, but it achieved nothing. Well, at least now, the messages in German are displayed correctly in UTF and forcing English does work:

$ LANGUAGE=en tcl
No command 'tcl' found, did you mean:    # CORRECT, this should be normal behaviour 
$ LANGUAGE=en:de:ro tcl
Der Befehl »tcl« wurde nicht gefunden, meinten Sie vielleicht: # This is German

Here is the output of locale as of now:

LANG=en_GB.UTF-8
LANGUAGE=en:de:ro
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY=en_GB.UTF-8
LC_MESSAGES=POSIX
LC_PAPER=en_GB.UTF-8
LC_NAME=en_GB.UTF-8
LC_ADDRESS=en_GB.UTF-8
LC_TELEPHONE=en_GB.UTF-8
LC_MEASUREMENT=en_GB.UTF-8
LC_IDENTIFICATION=en_GB.UTF-8
LC_ALL=
2
  • What does locale say? – muru Aug 27 '14 at 4:30
  • Added the output of locale to the question proper. – BogdanBiv Aug 27 '14 at 4:38
1

I think that the problem is the error line:

locale: Cannot set LC_MESSAGES to default locale: No such file or directory

When trying to print the messages, the C library will try the first locale in LANGUAGE which in your case is en but it has an error; so it switch to the second one which is de (german). And probably your de locale is not UFT-8 so you have the strange hex data (probably \xbb and \xab are some kind of opening-closing quotation marks).

BTW, which locale is en_RO? In my system I have just the following:

en_AG,en_AG.utf8,en_AU.utf8,en_BW.utf8,en_CA.utf8,en_DK.utf8,en_GB.utf8,en_HK.utf8,en_IE.utf8,en_IN,en_IN.utf8,en_NG,en_NG.utf8,en_NZ.utf8,en_PH.utf8,en_SG.utf8,en_US.utf8,en_ZA.utf8,en_ZM,en_ZM.utf8,en_ZW.utf8

so you probably added it from some non-standard package? (I do not know, just asking).

Have you tried to check if the language support is completely loaded? (Settings -> Language Support in Gnome, it may vary with Ubuntu flavors). It sometime got quite scrambled up and selecting the option gives you this:

enter image description here

In my system it works ok and it switches language ok:

romano@pern:~$ tcl
No command 'tcl' found, did you mean:
 Command 'tcm' from package 'tcm' (universe)
 Command 'tcal' from package 'gcal' (universe)
 Command 'tcs' from package 'tcs' (universe)
 Command 'tdl' from package 'tdl' (universe)
 Command 'tcc' from package 'tcc' (universe)
 Command 'tel' from package 'orville-write' (universe)
 Command 'tjl' from package 'pvm-examples' (universe)
 Command 'gcl' from package 'gcl' (universe)
 Command 'mcl' from package 'mcl' (universe)
 Command 'ncl' from package 'ncl-ncarg' (universe)
 Command 'tbl' from package 'groff-base' (main)
 Command 'tc' from package 'iproute2' (main)
 Command 'cl' from package 'cl-launch' (universe)
 Command 'ccl' from package 'cclive' (universe)
 Command 'ecl' from package 'ecl' (universe)
tcl: command not found

and

romano@pern:~$ LANGUAGE=it:en tcl
Comando "tcl" non trovato. Forse si intendeva:
 Comando "ncl" dal pacchetto "ncl-ncarg" (universe)
 Comando "ecl" dal pacchetto "ecl" (universe)
 Comando "tel" dal pacchetto "orville-write" (universe)
 Comando "ccl" dal pacchetto "cclive" (universe)
 Comando "tdl" dal pacchetto "tdl" (universe)
 Comando "mcl" dal pacchetto "mcl" (universe)
 Comando "tcc" dal pacchetto "tcc" (universe)
 Comando "tc" dal pacchetto "iproute2" (main)
 Comando "tbl" dal pacchetto "groff-base" (main)
 Comando "cl" dal pacchetto "cl-launch" (universe)
 Comando "tcm" dal pacchetto "tcm" (universe)
 Comando "gcl" dal pacchetto "gcl" (universe)
 Comando "tcal" dal pacchetto "gcal" (universe)
 Comando "tjl" dal pacchetto "pvm-examples" (universe)
 Comando "tcs" dal pacchetto "tcs" (universe)
tcl: comando non trovato

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.