2

I don't dual-boot. I've been using Ubuntu on my external hard drive for over a year with out any problems. I normally plug the drive into my laptop, Asus ux31a. I noticed a consistent issue that occurs every time I plug in a different drive with a linux distro on it (ubuntu, mint, etc). I get a message Minimal BASH-like line editing is supported. For the first word. TAB lists possible command completions. Anywhere else TAB Lists possible device or file complete. and this message will come up for both drives and prevent booting for both drives. My questions are:

  1. is this normal? Should only one linux-external-drive be used on 1 machine? (normal this message will come up after I plug in second linux-external-drive, I would have to fix by reinstalling linux on one of the drive using a live-cd and ONLY use that drive on the machine that was used for the installation).
  2. Can one linux-external-drive be used on multiple machines? The reason I ask is that it seems like the drive will only work with my laptop (which was used to install linux on the external drive) and it will not boot on other machines.

I'm sorry for the confusing questions. I don't know much of other ways to explain the issue. I wish there was a way to use multiple external drives on my laptop so I can use different distros without having to install multiple distros on one hard drive.

The routine I use for installing on external hard drive is as follow:

  1. boot a live-usb on my laptop.
  2. create / boot partition on the external drive I want to install on.
  3. create / partition on the external-drive I want to install on.
  4. Select sdb (which is my external drive, where i want the boot partion to be).

I want to make it clear that this will work fine as long as I don't plug in a different linux-external-drive into my laptop. the minute I do that, I will get the message above and neither drive will boot. I'm still learning info about grub and trying to understand more about the booting configurations in linux. I hope someone can enlighten me on the issue. Thank you.

  • Whenever I make a fresh install of Linux on a drive. I always choose that specific drive to install grub. Specifically, when I install on WD-500GB drive. I choose sdb for grub (b/c sda is my laptop internal drive). Then I will install Linux Mint on my Sandisk using the same method. But booting the Sandisk on the laptop will cause that message for both drives. Hope that clarifies. – bbnguyen Aug 27 '14 at 4:16
  • Should I be install grub on my laptop instead? – bbnguyen Aug 27 '14 at 4:17
  • No, you're doing it exactly as I would. I wonder, the grub menu entries - are they using some incorrect information? Wrong UUIDs? Or some assumption is being made. Can you post the grub.cfg of both disks to paste.ubuntu.com and add a link here? – muru Aug 27 '14 at 4:20
  • I'm really sorry. I wish I can. But after the issue I reinstalled both Ubuntu and Mint on my WD-500GB and see how it would work (which worked perfectly). The issue now is I reinstalled windows on my laptop and my WD-500Gb will not boot anymore. It seems like no matter which drive I select to install grub, it will automatically install grub on my laptop instead. I will reinstall the two distros on my different drives again to replicate the problem then come back to answer your question. Thank you. – bbnguyen Aug 27 '14 at 4:24
  • If you're able to reproduce this behaviour, please consider filing a bug. Meanwhile we can try to find a workaround. – muru Aug 27 '14 at 4:26
0

This will help you when you have to boot from the grub command line interface. Here are the steps I use if I have to do this:

search -f /vmlinuz

This returns partitions that contain the image I want. For example, if it returns (hd0,gpt6) then I would continue like this.

linux (hd0,gpt6)/vmlinuz root=/dev/sda6 

note: hd0 is sda, hd1 is sdb, and so on. gpt6 is the partition, so hd0,gpt6=sda6, just different notations.

initrd (hd0,gpt6)/initrd.img

boot

I usually use tab completion, so I might have a spelling error or something similar. Please look at the link for instructions that are more likely to be accurate.

Try running Boot-repair. This issue has happened to me on at least three separate occasions, and boot-repair has always come to my rescue. From the sound of it, it seems like when you try to use a different computer, grub is broken. Fixing the grub installation on the external drive specifically should fix the issue.

The problem when you plug in another drive, could be that the BIOS is trying to boot off the other drive. You should check in your BIOS Settings to make sure it's booting from the correct external drive.

  • 1
    I believe you are describing exactly what I am thinking. I've used grub-repair before and it does solve the issue. Which leads to my second question: Will my external-drive only work on the specific machine I used to do the installation? or should it have the capability to boot on multiple machines (granted bios configurations is set correctly)? – bbnguyen Aug 27 '14 at 4:28
  • @user308203 Yes, you should be able to boot from any machine. Think of the external drive exactly like a bootable thumb drive. That's how it should work, assuming correct bios settings and grub installment. – DrewDiezel Aug 27 '14 at 4:43
  • 1
    I tried your method and it revived function to my original external-hdd. I will reproduce the problem to play around with more during school break in about a month. I want to be able to provide accurate symptoms when I bring up this question again. Thank you. – bbnguyen Aug 27 '14 at 7:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.