0

During upgrade from 12.04 to 14.04 I got lots of errors about various items related to TeX. Most of them reported 'tex-common is not configured' as at least a part of the problem.

When I try to reinstall tex-common, I get the error: No file name for tex-common:i386

Other side effects of this problem are that I can no longer start Eclipse, and as you would expect Kile and other applications that manipulate LaTeX don't work any more.

Any help would be much appreciated.

  • Hi Peter, Eclipse is not dependent on texlive, if it does not start it is for some other reason. First off: try to remove all the existing packages with a command like sudo apt-get purge texlive* and then install it again. – Luís de Sousa Aug 27 '14 at 6:28
  • Didn't work, I'm afraid. I purged all the textlive packages (and deleted all the configuration files from /etc/texmf/texmf.d as instructed during the purge). I then tried to reinstall and got vast numbers of error messages like this: – Peter Aug 27 '14 at 15:30
  • Your comment is missing the error message. If you are unable to install packages your problem is certainly broader and not related to texlive per se. – Luís de Sousa Aug 27 '14 at 15:35
  • So I tried to install tex-common, but got the following error: ¿Desea continuar? [S/n] s Configurando tex-common (4.04) ... Running mktexlsr. This may take some time... done. Running updmap-sys. This may take some time... updmap-sys failed. Output has been stored in /tmp/updmap.s1B6Cu4l Please include this file if you report a bug. This file appears to be a binary file, so I can't get any help there. The error in my previous was followed by vast numbers of other ones all telling me that nothing could be done because text-common was not configured. – Peter Aug 27 '14 at 15:40
  • Sorry about missing error messages. They were all complaining that tex-common was not configured – Peter Aug 27 '14 at 15:42
0

This worked for me:

sudo apt-get purge tex-common
sudo update-updmap
sudo updmap-sys --syncwithtrees
sudo updmap-sys
sudo apt-get install texlive

During the first command above, pay attention to the list of packages that are removed along with tex-common. In my case it removed kile and a lot of other texlive advanced packages. You will need to reinstall them after.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.