I've added a new PPTP VPN connection under Network Manager -> VPN Connections -> Configure VPN. Now the connection is listed under "VPN Connections", but it's grayed out.

How can I debug this?

Whatever I've tried doesn't seem to help: checked the logs--no clues, toggled 'Available to all users', toggled 'Connect automatically', logged in and out a few times, etc.

It would be nice if Network Manager didn't gray the item out when it detects some configuration problems, but let me click the item and show some error message after that.

  • network-manager-pptp and network-manager-pptp-gnome are both installed.

UPD: I cannot reproduce the problem right now: it has cured itself it seems. Still I'd be grateful for debugging ideas if it happens again. I'd rather avoid running gdb against network-manager, which seems to be the ultimate way to solve this.

  • Please add the Ubuntu version to the tags. You shouldn't be able to save a bad configuration, so I don't think that's the problem. Do you have the packages network-manager-vpnc and network-manager-vpnc-gnome installed? You can run apt-cache policy PACKAGENAME in a terminal to check.
    – htorque
    Jul 3, 2011 at 17:38
  • Forgot to add that this was PPTP, not VPNC one. Added version tag.
    – alex
    Jul 3, 2011 at 17:52
  • Just checked: network-manager-pptp and network-manager-pptp-gnome are both installed.
    – alex
    Jul 3, 2011 at 18:37
  • Please accept Duke's suggestion. It works!
    – Alex
    Dec 14, 2016 at 6:43

4 Answers 4


I had the same issue on Ubuntu 12.10 and fixed it by restarting nm-applet like this...

killall nm-applet
nm-applet --sm-disable &
  • This actually worked!
    – Alex
    Dec 14, 2016 at 6:42
  • 2
    didn't work for me. I recently installed VKM recently though Jan 11, 2017 at 16:36

Try installing network-manager-openvpn and network-manager-vpnc and linux-pptp.

sudo apt-get install network-manager-vpnc network-manager-openvpn linux-pptp

I know it's PPTP but it can't hurt to try this.

If that doesn't work, try this:

  • Backup /etc/network/interfaces to /etc/network/interfaces.original.
  • Delete all lines from /etc/network/interfaces not including the string "lo" (leaving two lines, probably the first two, beginning auto and iface).
  • Reboot.

Hope this works for ya!

From http://ubuntuforums.org/showthread.php?t=974882

  • No, this is not the problem I'm facing. I can add a VPN connection, but cannot activate it, because the VPN connection item I've added is grayed out (disabled) in the NetworkManager menu.
    – alex
    Jul 18, 2011 at 14:35
  • just try it and then see if it works especially the linux-pptp
    – PitaJ
    Jul 18, 2011 at 21:55
  • I have all of the above already installed (and it's pptp-linux, not linux-pptp.) Now the problem has cured itself apparently, as I'm no longer able to reproduce it: the added connection isn't grayed out anymore. :-/
    – alex
    Jul 19, 2011 at 4:34

This is likely to be due to Gnome Keyring being locked, preventing you to access the connection.

This is apparently a known issue when using automatic login: The keyring doesn't get unlocked and it prevents you to do some things such as connecting to a VPN. As soon as the keyring gets unlocked (For example by trying to edit the connection settings) the VPN connection is not disabled anymore.

There are various options to unlock the keyring automatically when login, but the simplest I found was to just use a blank password for my keyring. Not very secure, but eh...

To change your keyring password, start the "Password and Keys" app.


I my case the VPN Connection was grayed out due to a Bridged Network connection which I did set up according to Simple Virtualization With Ubuntu 16.04 Linux and KVM

Work around: remove the bridged network connection

After removing the bridge I could again connect to VPN.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .