0

I'm really new to Ubuntu, Please excuse me if my question sounds stupid (also my bad English).

To save disk space, I had formatted my windows installation, and somehow I was able to install Ubuntu once again when the first installed copy of Ubuntu along with the windows start to failed.

My system has 2 hard disks: 1 of 500 GB which is encrypted, other one of 160 GB.

I partitioned and installed Ubuntu on 160GB HDD, then I was mounting the remaining 116GB of that drive and 500 GB on /media.

When I noticed my system runs without swap memory I tried editing fstab, still it doesn't mount swap partition.

My problem is, my system get hanged frequently, mostly when I browse using firefox/chromium. The system hangs so badly that I'm not able to get terminal by alt+f2, the only thing work there is Alt+PrtScrn+ REISUB.

I tried using mountall.

mountall: Unable to listen for privateconnections: Failed to bind socket "/com/ubuntu/mountall/server/": Address already in use
mountall: Disconnected from Upstart

Both nginx and Apache are running on my system, I have only 2GB of RAM.

I don't know where to start to bring my system to working condition. ( I'm stopping my experiments with Ubuntu, whew!!! )

Please advise me, buying an additional RAM or HDD will work here, I'm totally confused and upset that I'm not able to continue my works on this machine.

Update (1):

My system has swap memory:

sudo fdisk -l

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   957249089   478624513+  83  Linux

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1        86085632   312580095   113247232   83  Linux
/dev/sdb2        61450238    86085631    12317697    f  W95 Ext'd (LBA)
/dev/sdb5        78024704    81930239     1952768   82  Linux swap / Solaris
/dev/sdb6        61450240    78010367     8280064   83  Linux
/dev/sdb7        81932288    86085631     2076672   82  Linux swap / Solaris

Disk Utility 160GB

Disk Utility 500GB

Update (2):

sudo blkid

/dev/sda1: UUID="9609fc4c-ece8-4c9b-985e-c1271866aa4c" TYPE="crypto_LUKS" 
/dev/sdb1: LABEL="Ubuntu116GB-OS2" UUID="674b44fc-f619-4ca8-9d07-80a3d43d1b10" TYPE="ext4" 
/dev/sdb6: LABEL="Ubuntu8.5GB-OS1" UUID="bcd535b5-eef9-4d70-be33-07153802b2ba" TYPE="ext4" 
/dev/mapper/cryptswap1: UUID="121099fc-9fa2-4051-9253-b2938c2e7468" TYPE="swap"

sudo lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL

NAME                  FSTYPE        SIZE MOUNTPOINT LABEL
sda                               465.8G            
└─sda1                crypto_LUKS 456.5G            
sdb                               149.1G            
├─sdb1                ext4          108G /          Ubuntu116GB-OS2
├─sdb2                                1K            
├─sdb5                              1.9G            
├─sdb6                ext4          7.9G            Ubuntu8.5GB-OS1
└─sdb7                                2G            
  └─cryptswap1 (dm-0) swap            2G [SWAP] 

cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0

# / was on /dev/sdb1 during installation
UUID=674b44fc-f619-4ca8-9d07-80a3d43d1b10 /               ext4    errors=remount-ro 0       1

# swap was on /dev/sdb7 during installation
#UUID=a36435c9-e579-470a-92fc-e477afd501bc none            swap    sw              0       0

#/dev/mapper/cryptswap1 none swap sw 0 0
UUID=8e474f34-7b1d-49aa-81f1-607192912785 none swap sw 0 0

However, I can manually load swap by:

sudo swapon /dev/mapper/cryptswap1

My system has two Ubuntu installations, I'm running every command now from OS2 which is on 116GB ext4 (Please see image), I would like to delete the OS1 on 8.5GB ext4 and make use of the two swap partition as a single one of 4GB

0

Not enough memory or swap space

With only 2 GiB of main memory and without swap space you're likely to run into problems. I suggest you create and mount a swap partition for that. You can easily set up an encrypted swap partition with dm-crypt, which will break resuming from suspend-to-disk because of the random one-time volume keys.

To delete "OS1" simply delete that partition with palimpsest, gparted, fdisk or whatever disk partitioning tool you prefer. Do the same for the existing swap partitions to create the larger new one. You can also swapon multiple partitions (works with fstab too).

Other possible causes

This could also be broken hardware or a bad driver. Since the issue correlates with web browsing I suspect a RAM module gone bad or a faulty graphics adapter driver, but you should sort out the swap issue first since that seems more problematic.

  • thanks to your reply, I was able to figure out there was an additional os installation which works more smoothly. (ie, has more disk space in its root / ). So I would like to keep that, please see my updated question. – KrIsHnA Aug 27 '14 at 13:34
  • I edited my answer to include a link to a guide for encrypted swap. – David Foerster Aug 27 '14 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.