As the title says, after an update sometime last week, logging into my user account only gets as far as changing the background from the login screen's standard to my personal wallpaper.

No dashboard or anything else appears: I can only move my mouse pointer around and fruitlessly make selection boxes and right-clicks.

There are many questions with similar problems and I have tried all of the following already (in order):

I went into a terminal with Ctrl+Alt+F1 and ran apt-get update and apt-get upgrade to upgrade 8 packages I had which were still marked as uninstalled. They seem to have installed successfully but the problem persisted after a reboot.

I then tried installing compiz-settings manager as per the instructions at Unity doesn't load, no Launcher, no Dash appears and using it to re-enable the Unity Plugin. Still no noticable change after a reboot.

I have also tried uninstalling and reinstalling lightdm, ubuntu-desktop and unity via the terminal, also with no noticable changes after a reboot.

I renamed my .Xauthority file so that a new one would be created as per the instructions at Ubuntu gets stuck in a login loop. That also did not solve the problem. The Xauthotity file is owned by me. It doesn't look like there is anything wrong in my .profile file either.

Lastly, I found a suggestion on one of these many similar threads that I should disable the desktop icons. I ran some command in the terminal to the effect of "gnome show-icons false" and after that for some reason the wallpaper doesn't even appear now and when I tried to reverse the change by running the command again with the value "true" instead of false I got an error message to the effect of "unable to change" due to permissions or settings or something.

Important points: I am able to login as a guest with absolutely no problems at all, which suggests to me that this is not the result of a graphics driver problem.

I freshly installed Ubuntu 14.04 (64-bit amd) around the end of May: this was not an upgrade from an old version. I have had no problems until now.

I would greatly appreciate any assistance which you could provide.

Update: 08-30-2014 After a week, I logged back into a terminal and performed some more apt-get updates and upgrades, still to no avail, but I was able to make a new user account within the terminal and log in using the new account with little more than a slight delay!

I have already checked/removed my old .Xauthority and .profile files to make sure that they are not the problem, and I do not know what other user-specific information may be causing this.

If no one can help me find the source of this problem, I would also appreciate any suggestions as to an easy way to migrate my data over to my new, working account from my old one. For example, my applications, my software, my virtual machine, etc.

Any help would be greatly appreciated.

nautilus --force-desktop &

Found something that says by running the above line will get you wallkpaper back. Also, possibly gnome-tweak-tool will also fix the issue

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.