I am using a Dell Inspiron 15R 5520 laptop running Ubuntu 14.04 with kernel version 3.13.0-34 generic. Since installing the OS, I have been having issues with my computer's fan spinning at its maximum speed for prolonged periods of time. I tried installing TLP, which works sometimes, and I also tried i8kutils but it only turned my fans off. This fan issue occurs more frequently when on AC power, and I cleared the exhaust of dust already.

Why is this happening?

I am not an advanced Linux user, but I am open to any suggestions you have at this point. Listening to a fan running at max is annoying.

  • If that laptop has AMD CPU or GPU, then I don't believe there is a fix for it yet. AMD CPU and GPU's get very hot. Is that also in your case? Aug 27, 2014 at 11:49
  • Hello Dan, I determine the cause of the fan issue. I needed to edit the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" in my grub configuration file found at /etc/default/grub so that it reads, GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=!Windows 2012" My fans are normal now; thank you for your response!
    – user311982
    Oct 15, 2014 at 20:41
  • Can someone explain what is the connection between grub, which I guess is only a boot manager, and the fan speed?
    – jabal
    Feb 5, 2015 at 19:05
  • Hi Jabal, by editing the grub configuration file you can enable, disable, or modify features related to your hardware for a computing session. For example, if you wanted to disable ACPI, you can do that. You can also fix problems with your display brightness not adjusting when you use your F keys so that you can change said brightness. In terms of how the answer I posted below relates to fan speed, exactly, I have no idea. I found this on an Arch Linux site several months ago, but I don't have the link. I was desperate and this solution worked wonderfully.
    – user311982
    Feb 10, 2015 at 7:01

3 Answers 3


Fan speed is normalized by editing the line


in the grub configuration file found at /etc/default/grub so that it reads

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=!Windows 2012"

Follow these steps to try this solution:

  1. Open a terminal, type sudo gedit /etc/default/grub, and press Enter
  2. Enter your login password and press Enter. The password will not be displayed as you type it.
  3. Edit the line


    such that it reads

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=!Windows 2012"
  4. Click "Save", wait a few moments for the file to save, then close the text editor.

  5. In the terminal, type sudo update-grub and hit Enter

  6. Finally, shut down your computer. Shut it down completely: don't restart it.

Once you turn your computer back on and select the linux operating system whose grub file you edited earlier, your fans should be working normally. This solution has worked for me on Ubuntu, Linux Mint, Elementary OS, and LXLE on a Dell Inspiron 15R 5520 laptop.


I also have a Dell inspiron 15r se. Thanks to vitorafsr's post on launchpad, I could solve my problem.

Just install i8kutils by running

sudo apt-get install i8kutils

in the command line.

If that doesn't work have a look at the i8kutils project page.

  • 1
    When I installed this it turned the fan completely off and it stayed off, even as temperatures climbed to 70C and higher. I tried regulating with i8kfan command, but it wouldn't turn the fan on for more than 2 seconds.
    – Degru
    Oct 28, 2015 at 21:24
  • 1
    In this case you should make the config files as you can find here. If the fans doesn't start, you should delet i8kutils, reboot and reinstall it, with the existing config files.
    – SiGe
    Nov 17, 2016 at 14:06
  • 1
    There's more explanation about this solution here cyberciti.biz/faq/…
    – wranvaud
    Apr 18, 2017 at 16:14

I think i have just found an easier solution and it' working fine on my Dell Inspiron 3521 15R with i3 processor.

The solution is called TLP. I know that TLP is mainly used to save battery power but it's working even if i'm connected to AC and without limiting CPU resources.

First, check if you have installed on your system laptop-mode-tools and uninstall it:

sudo apt-get purge laptop-mode-tools

Then, install TLP:

sudo add-apt-repository ppa:linrunner/tlp
sudo apt-get update
sudo apt-get install tlp

Edit the file /etc/default/tlp:

sudo nano /etc/default/tlp

and look for #CPU_MAX_PERF_ON_AC=100. Uncomment the line and save the file pressing CTRL+O

Start TLP:

sudo tlp start

and if you are lucky enough your fan will calm down a lot.

NOTE: intel_pstate must be enabled on your system. It should be already enabled by default. You can check it digiting the following command in the terminal:

grep -i pstate /boot/config-$(uname -r)

The output should be:



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .