I have Ubuntu 14.04 LTS, and am running it on a Sony Vaio VGN-CR12OE. It is the only operating system. I am trying to connect to my college's WPA WiFi. My settings for this WiFi connection are as follows:

Security: WPA & WPA2 Enterprise
Authentication: Protected EAP (PEAP)
Anonymous identity: <I've been leaving this field blank>
CA certificate: AddTrust_External_Root.crt <see below fixes I have already tried>
PEAP version: Automatic
Inner authentication: MSCHAPv2
Username: <my username>
Password: <my password>

Warns me that I haven't attached a CA certificate Keeps warning that I don't have one, regardless of whether I check "don't warn me again" and click "ignore". I give CA certificate from /usr/share/ca-certificates/mozilla/AddTrust_External_Root.crt Stops warning me that I don't have CA certificate

When I try to connect, it keeps prompting for password I tried checking the box found at WiFi menu > Edit Connections > "General" tab > "All users may connect to this network" Still keeps prompting for password

  • This bug was marked fixed: bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/… so updating to the latest version should fix this without manual editing. – muru Aug 25 '14 at 21:17
  • Thanks for your comments. I had already tried setting system-ca-certs=false before, and it didn't help, even when I did recreate the connection. As to your second comment, what exactly needs the updating, and how do I do this updating? – Stuart Ryerse Aug 26 '14 at 2:32
  • The network-manager-applet package needs updating. It should be in version or higher. But if system-ca-certs=false didn't help, this might not either. – muru Aug 26 '14 at 2:37
  • I'd like to try setting system-ca-certs=false one more time, in case I happened to do it wrongly last time. In the /etc/NetworkManager/system-connections/MYCONNECTION file, where should I add that line? there is no line in there already that says "system-ca-certs=true", so I don't know where to add that line. – Stuart Ryerse Aug 26 '14 at 2:50
  • If you have added a CA certificate, that line wouldn't appear or apply. Did you create the connection with the CA certificate this time? – muru Aug 26 '14 at 3:03

The fix that I finally found is the answer in this thread: How to connect to WPA2/PEAP/MSCHAPv2 enterprise wifi networks that don't use a CA_Certificate, like Eduroam. I will sum it up here.

All I did was add the auth-alg=open to the file /etc/NetworkManager/system-connections/MYCONNECTION, at the bottom of the [802-11-wireless-security] section of the document. I hope this helps more people than just me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.