0

I have Windows 7 on a separate disk (sdb) as it came from the factory. To protect it I disconnected it while installing Ubuntu 14.04 on the sda disk. Then I connected the sdb drive and expected to see a choice in the boot menu for booting Windows 7. But it was not there. I'm pretty sure I followed the same procedure when I upgraded to 12.04 and it worked then. It looks like I have to modify grub to get it to see Windows 7 on sdb. Could you recommend a safe way to do this? Is there a tool that I can use? Thanks in advance...

1

With both disks connected, boot into Ubuntu in sda.

Open a terminal by pressing Ctrl+Alt+T.

Enter (or copy and paste in the terminal)

sudo update-grub 

Enter your Ubuntu to login password when prompted. The Cursor won't move when you type the password. This is normal.

On next restart, GRUB should show both Ubuntu and Windows

0

You can config/fix grub after installing with super grub2 disk.

All you need is to burn the ISO on a CD/DVD and boot into the image.

You can download it from here:

supergrubdisk.org

0

user68186 has already left a perfect answer for doing as you've asked, and if that doesn't work you can always open grub's custom_40 file and write an entry by hand. Personally I would suggest leaving your system as is.

Currently your bootloaders are nice and neatly stored on seperate drives allowing you to easily replace you operating systems at any time because they aren't aware of each other, and you CAN choose which OS to boot by pressing the appropriate F key to access you system's quick boot menu. In the quick boot menu just pick which hard drive you wish to boot. Hard drive one will boot Ubuntu, and hard drive two will boot Windows.

0

First, thanks for all the great advice! I solved the problem by installing grub-customizer following Ubuntu forum: HOWTO: Grub Customizer (Google: grub-customizer). It says to install it with:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer

sudo apt-get update

sudo apt-get install grub-customizer

It can then be run with: Applications->System Tools->Administrator->Grub Customize. It finds Windows 7 on sdb. All I had to do then was to File->Quit and select the "Update Grub" button (I don't remember the actual button label words). When I rebooted, Windows 7 was on the list!

  • 1
    Do you mean that the sudo update-grub did not work, while the grub-customizer did the same thing? – user68186 Aug 26 '14 at 15:52
  • +1 to user68186's comment. I'm fairly confident that grub customizer was just running an update-grub in the background and that you could have saved yourself some trouble by running his/her command from a terminal. Nothing wrong with grub-customizer (I like it for the convenience of fine-tuning boot options, backsplash, password, etc), but user68186's answer from yesterday is definitely the simplest and most straight-forward way to get to where you wanted to be originally. Please do him the courtesy of marking his answer as the correct one unless you tried his suggestion without success. – MGodby Aug 26 '14 at 19:40
  • Thanks @MGodby. It will be good to know if the command line does not work, but the GUI interface does for some reason. I have nothing against GUI tools like Grub-customizer. – user68186 Aug 27 '14 at 2:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.