I'm using Ubuntu 14.04. I originally wanted auto-connect VPN upon login, but after much trial and error and connection issues it looks like my network manager is corrupt.

When I try to connect Wifi by clicking Network Indicator -> VPN Connections -> (My VPN) I got no acknowledgment from the GUI that it could not connect.

When I did tail /var/log/syslog, I got:

Aug 25 19:59:01 NetworkManager[1041]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Aug 25 20:00:07  NetworkManager[1041]: <info> Starting VPN service 'openvpn'...
Aug 25 20:00:07 NetworkManager[1041]: <info> VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 3544
Aug 25 20:00:07 NetworkManager[1041]: <info> VPN service 'openvpn' appeared; activating connections
Aug 25 20:00:07 NetworkManager[1041]: <error> [1408993207.745279] [nm-vpn-connection.c:1374] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.
Aug 25 20:00:07 NetworkManager[1041]: <info> Policy set 'MY WIFI CONN' (wlan0) as default for IPv4 routing and DNS.
Aug 25 20:00:13 NetworkManager[1041]: <info> VPN service 'openvpn' disappeared
  • 1
    Any trustworthy solutions for this issue, I am experiencing the same? – neowinian Dec 3 '14 at 9:48
  • Not posting as an answer since I'm on a different distro, but... try rebooting. I just encountered the same and after rebooting it worked. – D-side Apr 13 at 14:23

I just had the same issue and Plant Maven's answer was correct.

Instead of deleting the config files in /etc/NetworkManager/system-connections/ I moved them to another folder, so I could compare.

The only difference between the old config file and the new one is in a VPN connection I just re-created from scratch and it's the UUID.

No idea why the old file wouldn't work. I suspect it's something related to the keyring.

In my case selecting the password option "Store the password for all users" got it working. All other options produce the mentioned error.

  • It's so jokey, but it works for me too. – shgnInc Apr 7 at 5:17

I just rm'd all files in /etc/NetworkManager/system-connections/ and restarted Ubuntu 14.04. Problem solved. I know it was the last software update because I updated and shutdown. The next time I started up Ubuntu, the network kept dropping connection.

Please observe that the gnome Network Manager has changed and now when you edit connections you have a symbol to the right in the Password field that indicates how the password should be handled, "Store password only for this user", "Store the password for all users", Ask for this password every time and password is not required. You need to select "Ask for password every time" if you want the password question the second time This confused me a bit....

  • This worked for me. Thanks! – DavidW Oct 23 '17 at 19:30
  • Nevermind, it stopped working and now I can't get my VPN to connect. – DavidW Nov 2 '17 at 22:22
sudo apt-get install --reinstall network-manager

After running this command , I tried connecting to the vpn service, I was thankfully once again prompted for my vpn password and able to connect to the service.

After some weeks, I still have issues sometimes. When I log out and log in it resolves itself most of the time. I am using WICD network manager also now, due to sometimes wifi stops working altogether !

I too had this error although I encountered it after a week of flawless OpenVPN usage. I found an obscure idea to restart the dbus service in Ubuntu.

    sudo service dbus restart

It might be wise to concat another command to this command to restart your GUI since a power button reboot was necessary for me after I executed this command

check this out maybe you should purge network manager and reinstall the network-manager package you download, or from live cd

I tried moving/deleting the connections in /etc/NetworkManager/system-connections/, choosing the option "Store the password for all users" and "The password is not required" (for my VPN, it isn't), reinstalling network-manager, restarting Ubuntu, .. None of these worked.

My connections worked, but only periodically. I only tried through the openvpn command a few times, but it worked flawlessly.

To fix it, edit the connection and click

Advanced -> tick Accept authenticated packets from any address (Float)

then save your connection. This was the only thing that worked for me.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.