0

I know this isn't exactly a Linux problem but I'm getting no help anywhere else. I'm trying to reinstall ubuntu onto my laptop but I keep getting the error "No bootable device -- insert boot disk and press any key" but I have it on my USB ready to install but for some ready it won't recognize it at all. I've tried everything I could find on the internet and none of them are useful, please help!

  • 2
    It is not clear how you are trying to reinstall Ubuntu and when you get the error "No bootable devece..." Do you get it when you try to boot from the internal hard drive? Do you get it when you try to boot from the USB? Please edit your answer above with the new information. – user68186 Aug 25 '14 at 17:42
  • Yes I've got it first in the boot options menu, I've tested it in my computer it comes up saying it's ready to install but when i go onto my laptop to boot from USB to install it on my laptop it will come up with that error saying that there is not bootable device, I've tried if with a DVD/CD as well, comes up with the same error. I know for a fact that it's on the USB ready to install and for some reason it's not recognising the USB at all, I'm not 100% sure why this is happening and not sure how to fix it. – christian ashton Aug 25 '14 at 17:50
  • Are you booting both computers in UEFI or both in BIOS mode? Otherwise it may be flash drive not configured for correct boot mode. You have to select and most systems are now UEFI. – oldfred Jun 29 '20 at 19:40
0

Assuming your computer supports boot from USB, you may have to enable it to do so in your BIOS settings. Access the BIOS settings by pressing the appropriate key at startup (varies from machine to machine, typically one of the function keys. google your machine to find out what it is), then go to the boot options and ensure boot from USB is enabled.

If this fails, it's possible the USB you created is no good and you should try putting a fresh image on it. unetbootin is popular and has a reputation for not causing as many errors as other similar utilities.

0

Sounds like you're using a UEFI system. When you create usb installers they are typically for mbr bios only, it depends what program you use to make it. Install using a DVD and it should work fine.

0

I had the same problem installing ubuntu! Here is what to do.

  1. Boot to BIOS
  2. On security, make USB on the top.
  3. Make sure that the USB has a good copy of ubuntu
  4. Click 'try ubuntu'
  5. install efibootmgr
  6. Change so boot order so ubuntu is at the top
  7. Unplug USB
  8. Reboot
    It worked with my computer. I'm sorry if it doesn't work with yours.
0

What helps me is preparing usb with software "unetbootin", you can install it from command:

wget unetbootin.sourceforge.net/unetbootin-linux-latest
chmod +x ./unetbootin-linux-*
sudo apt-get install p7zip-full
sudo ./unetbootin-linux-*

It is ofter a file sistem problem. Try with fat, it may help. NTFS is a file sistem based on windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.