4

I have recently installed Ubuntu 14.04.1 LTS and I am having trouble using Amazon Instant Video. When I click on a video to play there is no option to play it, it just says that I can play it on a compatible device (kindle, phone,...) is there some package or something that I need to install?

Thanks for any help

I have successfully (I think) implemented the solution below but I still have the same problem.

After following the below I get:

nathan@nathan-S400CA:~$ sudo mkdir /etc/hal/fdi/preprobe   
[sudo] password for nathan:     
mkdir: cannot create directory ‘/etc/hal/fdi/preprobe’: File exists    
nathan@nathan-S400CA:~$ sudo mkdir /etc/hal/fdi/information    
mkdir: cannot create directory ‘/etc/hal/fdi/information’: File exists    
nathan@nathan-S400CA:~$ /usr/sbin/hald --daemon=yes --verbose=yes    
18:56:04.123 [I] hald.c:672: hal 0.5.14    
18:56:04.123 [I] hald.c:673: using child timeout 250s    
18:56:04.123 [I] hald.c:685: Will daemonize    
18:56:04.123 [I] hald.c:686: Becoming a daemon    
nathan@nathan-S400CA:~$ rm -rf ~/.adobe
7
  • Did you reboot ?
    – Mark Kirby
    Commented Aug 25, 2014 at 17:33
  • @markkirby Yeah, and it has done something as I can now watch other videos (on sites such as 4od) but when on Amazon instant there isn't even an option to press play it seems to think that I am looking at it from a device that isn't compatible for some reason
    – hmmmm
    Commented Aug 25, 2014 at 17:46
  • I updated the answer to include the next step for you.
    – Mark Kirby
    Commented Aug 25, 2014 at 17:49
  • @markkirby Thanks. I have entered those commands and posted what I got above into my answer
    – hmmmm
    Commented Aug 25, 2014 at 17:58
  • Reboot make sure the web browser is closed then open a terminal and type hald
    – Mark Kirby
    Commented Aug 25, 2014 at 18:01

1 Answer 1

9

You need this flash plug in

sudo add-apt-repository ppa:mjblenner/ppa-hal
sudo apt-get update 
sudo apt-get install hal

Here is a post with more information LINK Post number 3

If after a reboot it wont work then copy paste this to a terminal, ONE LINE AT A TIME

sudo mkdir /etc/hal/fdi/preprobe
sudo add-apt-repository ppa:pipelight/stable
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi
sudo pipelight-plugin --update
sudo mkdir /etc/hal/fdi/information

/usr/sbin/hald --daemon=yes --verbose=yes

rm -rf ~/.adobe

Do not be worried by these commands enter them one at a time and tell me of any errors ,reboot when you are finished.

OK If this is not working for you we will try another way, open terminal run one at a time

sudo add-apt-repository ppa:pipelight/stable
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi
sudo pipelight-plugin --update

If a Microsoft core fonts licence screen comes up, first perss the tab key and then enter.

next run this command (this undoes what we first tried)

sudo apt-get remove --purge hal

And finally

sudo pipelight-plugin --enable flash

You could reboot here don't think you need to up to you.

Open your web browser and go to your video, the browser shoud automaticly try to download a plug in, give it permission if you have to.

When it is installed close your browser then open it again and it should work

To get silverlight close the browser

sudo pipelight-plugin --enable silverlight

Open the browser go to the video and the plug in will install then restart the browser.

18
  • Is there anyway that I can do this without the use of command lines and so on just using th gui?
    – hmmmm
    Commented Aug 25, 2014 at 15:33
  • 1
    Why I wrote all the code for you copy and paste into the terminal, copy one line press enter,enter your password, say yes or press enter if it asks, repet for the last two lines.
    – Mark Kirby
    Commented Aug 25, 2014 at 15:36
  • I made it even simpeler for you only one command copy the whole thing and paste in a terminal,enter your password, press enter if it ask you for confirmation. Job done
    – Mark Kirby
    Commented Aug 25, 2014 at 15:39
  • 1
    @Jorge thanks I did not realize the first command is add-apt and the rest apt-get, so could not do one code, have fixed
    – Mark Kirby
    Commented Aug 25, 2014 at 17:11
  • 1
    Ok In firefox go to plug ins and find User Agent Overrider. Install this use its icon to change to a firefox windows option and try again
    – Mark Kirby
    Commented Aug 25, 2014 at 19:37

Not the answer you're looking for? Browse other questions tagged .