17

I recently have installed Okular on my Ubuntu 14.04.

The problem is when I open pdf files, okular gives me the error "Can not find a plugin which is able to handle the document being passed."

When I ran Okular by Terminal, this is the message I get.

admin@me:~$ okular ex01.pdf
okular(14100)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found! 
okular(14100)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found!

okular(14100) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14100) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14100) KPixmapSequence::frameSize: No frame loaded 
okular(14100) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14100) KPixmapSequence::frameSize: No frame loaded 
okular(14100) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14100) KPixmapSequence::frameSize: No frame loaded 
okular(14100) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14100) KPixmapSequence::frameSize: No frame loaded 
okular(14100) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14100) KPixmapSequence::frameSize: No frame loaded 
okular(14100) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14100) KPixmapSequence::frameSize: No frame loaded 
okular(14100): No ksycoca4 database available! 

okular(14100)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "okular/Generator"  not found 
okular(14100)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(14100)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(14100)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(14100)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(14100)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(14100): No ksycoca4 database available! 

okular(14100)/kdecore (trader) mimeTypeSycocaServiceOffers: KMimeTypeTrader: mimeType "application/pdf" not found 
okular(14100): No ksycoca4 database available! 

okular(14100)/kdecore (trader): KMimeTypeTrader: couldn't find service type "okular/Generator" 
Please ensure that the .desktop file for it is installed; then run kbuildsycoca4. 
okular(14100)/okular (app) Okular::Document::openDocument: No plugin for mimetype '"application/pdf"'.
okular(14100): Couldn't start knotify from knotify4.desktop:  "KLauncher could not be reached via D-Bus. Error when calling start_service_by_desktop_path:
The name org.kde.klauncher was not provided by any .service files
" 
okular(14100)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "The name org.kde.knotify was not provided by any .service files" 

X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20 (X_GetProperty)
Resource id:  0x2a0002e
okular(14110) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14110) KPixmapSequence::frameSize: No frame loaded 
okular(14110) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14110) KPixmapSequence::frameSize: No frame loaded 
okular(14110) KPixmapSequence::Private::loadSequence: Invalid pixmap specified. 
okular(14110) KPixmapSequence::frameSize: No frame loaded 
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20 (X_GetProperty)
Resource id:  0x2a0001d
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20 (X_GetProperty)
Resource id:  0x2a0001d

I would be much appreciated for any suggestion to solve this problem. Thanks a lot :)

  • Can you add to question the command you typed to get error, Thanks. – ctrl-alt-delor Aug 25 '14 at 11:07
  • Is libpoppler-qt4-4 installed? – hal7df Aug 27 '14 at 3:13
24

This was quite the annoying one, but:

sudo apt-get install kdelibs5-plugins kdelibs5-data oxygen-icon-theme
4

I had the same error message. In my case Okular was installed with sudo, and the KDE dependencies were installed into the home folder under .kde, but with root as owner and group.

I changed by running:

sudo chown -R youruser .kde    
sudo chgrp -R youruser .kde

then it worked normal.

3

According to linux mint release notes in section "Issues with KDE Apps"

If you're experiencing issues with KDE apps (Okular, Gwenview, KStars..etc) run the following command:

apt install kdelibs-bin kdelibs5-data kdelibs5-plugins

Note: These issues do not affect the KDE edition. A regression in KDE 4.14 prevents these applications from working fine out of the box outside of KDE.

1

Open Synaptic Package Manager, and search for kde-core-devel

Install all packages under the version 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1. Then search for oxygen, and install the oxygen icon theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.