2

I'd like my HP Bluetooth Mouse x4000b (no usb dongle) to connect automatically when starting my HP laptop (Ubuntu 14.04), but I can't succeed in it : I'm forced to do it manually by clicking the connect button. I know this topic has been answered many times, but no solution worked for me.

Here's what I tried so far :

  • Creating the file /etc/default/bluetooth with lines :

    HIDD_ENABLED=1
    HIDD_OPTIONS="--connect F0:65:DD:7D:EC:A0 --server"
    
  • Putting hciconfig hci0 reset at the end of /etc/init.d/bluetooth

  • Putting

    /etc/init.d/bluetooth stop
    sleep 1
    /etc/init.d/bluetooth start
    

    in /etc/rc.local

None of these solution worked, I've read a lot of topics but couldn't find a solution ... that's why I'm asking that here, hoping you can help me troubleshooting that.

Update:

ray@ray-HP-EliteBook-840-G1:~$ hciconfig 
hci0:   Type: BR/EDR  Bus: USB
BD Address: F8:16:54:02:9F:62  ACL MTU: 1021:5  SCO MTU: 96:5
UP RUNNING PSCAN ISCAN 
RX bytes:4672039 acl:306914 sco:0 events:6516 errors:0
TX bytes:36591 acl:372 sco:0 commands:401 errors:0

ray@ray-HP-EliteBook-840-G1:~$ bluez-simple-agent hci0 F8:16:54:02:9F:62
Creating device failed: org.bluez.Error.ConnectionAttemptFailed: Page Timeout
0

OK To run at start up please, open start up applications from dash and choose new. Name it whatever you want and in the command box copy

sudo hidd --connect F0:65:DD:7D:EC:A0

Save it reboot, cross your fingers.

| improve this answer | |
  • Thanks, but I've read this guide already and it doesn't match my needs (my mouse is already paired, plus it have no dongle). And even when I try it, the trusted and connect commands seem to be unknown and it doesn't work – Ray B. Aug 25 '14 at 11:44
  • Okay, thanks for the precision. But as I said, when I try, this doesn't work ... ray@ray-HP-EliteBook-840-G1:~$ sudo bluez-simple-agent hci0 F8:16:54:02:9F:62 Creating device failed: org.bluez.Error.ConnectionAttemptFailed: Page Timeout – Ray B. Aug 25 '14 at 12:16
  • sudo bluez-simple-agent hci0 F8:16:54:02:9F:62 This is not the correct command sudo bluez-simple-agent connect F8:16:54:02:9F:62 is what I said to use – Mark Kirby Aug 25 '14 at 12:28
  • Well it doesn't work either ... :( ray@ray-HP-EliteBook-840-G1:~$ sudo bluez-test-input connect F8:16:54:02:9F:62 Traceback (most recent call last): File "/usr/bin/bluez-test-input", line 37, in <module> device = adapter.FindDevice(args[1]) File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in call return self._proxy_method(*args, **keywords) File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in call **keywords) dbus.exceptions.DBusException: org.bluez.Error.DoesNotExist: Does Not Exist – Ray B. Aug 25 '14 at 12:31
  • So this isthe error from the command sudo bluez-simple-agent connect F8:16:54:02:9F:62 – Mark Kirby Aug 25 '14 at 12:35
0

This may not apply though I went between dell and logitech support to find out why my logitech BT mice never autoconnect back to the systems and nobody ever supports it. I had to learn the hard way. Maybe this isn't helpful just figured I'd share my hard learned lesson.

None of my BT devices every connect to any OS/Device other than tablets/cell phones automatically. I've found rule of thumb is I have to unpair/remove the device from the OS/system then reconnect as after the device connects to another device it won't autoconnect to device one after it's most recent connection was device two.

| improve this answer | |
0

Remove your BT mouse and add it again assigning "0000" PIN for pairing, do not use default or auto PIN option. Worked for me.

| improve this answer | |
0

Try blueman-manager. Probably you need to install it using apt-get install blueman.

Install it by use your Terminal, Run ”sudo apt-get install blueman“ This is a bluetooth manege program.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.