0

I'm running Lubunto 14.04.1 LTS. PC is a 2004 HP ze4200 laptop: 1.8 ghz Celeron M with 1 gb RAM and 80 gb drive. Was running fine on WinXP SP3 and I cleaned the drive off to test Lubuntu 14 LTS. No anti-virus is installed yet. I enabled the CPU resource monitor to see how various programs drag the OS.

Using Firefox 31 online right now, I see doing basic functions like openning a new tab and scrolling down a page are using 100% CPU time, ocassionally for 10-30 seconds. In fact some pretty basic aps like Leafnote hit 100% for a second. Wordpad never did that. Lubuntu Software Center locks things up at 100% for 10 seconds. Just typing here shows a 60-80% spike every character. Running the mouse around the screen for 10 seconds results in a sustained 100% load during that time. Right now, if I let the PC rest just idling Firefox and not doing anything with it, CPU use bounces from 20-40% all by itself.

WinXP idles at 2-10% and it's considered not good for it to be above 20%... something odd must be happening. Sure, XP will give similar higher CPU cycles with program use, but it's not locking and slogging like this.

Lubuntu is supposed to be a light OS and by memory usage it is and I'm happy since this is an old PC maxed for memory upgrades. However, being used to doing some tuning and wary of abnormalities going on in the background, the CPU use indicates things going on that I want to know about and perhaps apply a tweek or two. Recommendations are appreciated.

And this 300 point "new tags" restriction bites!

  • You do understand Windows xp is 10 years old when it was designed PCs like yours were science fiction, with lubuntu the OS is still Ubuntu, just as modern and bolted with features, Lubuntu is simply a desktop change for low end GPU users. Please look at this to suit your needs better puppylinux.org/main/Overview%20and%20Getting%20Started.htm – Mark Kirby Aug 25 '14 at 7:58
  • Actually, this PC has a "Made for XP" sticker. My old install CD is the 2003 build and I had applied the SP3 update. It was never a race horse but it served well and reliably. My stated PC specs are 40x better CPU and 8x more RAM than those specified as official minimum (= just a P2 and 128mb RAM). I'm most interested in what's going on in the background of Lubuntu and what control is to be had over it. If something is wrong, I want to find out what and why. I did look at Puppy before choosing Lubuntu. That would've gone on my P3-666 376mb (Win2000) machine... had I not recycled it last month. – Jopower Aug 25 '14 at 8:35
  • @markkirby actually, I've used Debian gnome-shell on an old pentium4 xp computer and it runs great without sacrificing anything and Xubuntu seems to use less CPU than Lubuntu. That same computer runs Ubuntustudio without skipping a beat. – mchid Aug 25 '14 at 8:36
  • Is this relevent to you ? ubuntuforums.org/showthread.php?t=2123906 – Mark Kirby Aug 25 '14 at 9:01
  • Open a terminal type top and check these stats to see if a specific program caused a CPU spike – Mark Kirby Aug 25 '14 at 9:09
2

There are lots of things you can, and need to do, to improve the performance of your system.

First, install thermald to control laptop temperatures:

sudo apt-get install thermald

More info can be found here wiki.ubuntu.com/Kernel/PowerManagement/ThermalIssues

Next, install TLP. TLP helps save power and maximize performance. Run these commands to install TLP:

sudo add-apt-repository ppa:linrunner/tlp
sudo apt-get update
sudo apt-get install tlp tlp-rdw

You will need to edit the following file before you start TLP:

sudo leafpad /etc/default/tlp

Go through the settings and set them accordingly. Most importantly you must set the following line near the beginning of the file:

TLP_ENABLE=1

Every line that begins with a "#" will not be used by the system so remove any "#" to enable a setting or add a "#" to the beginning of a line to do the opposite. When you are done, save the file before closing and then run the following command:

sudo tlp start

More info can be found here: prevent-your-laptop-from-overheating

Furthermore, make sure your hardware sensors are properly detected. Install lm-sensors with this command:

sudo apt-get install lm-sensors

And run the following command to properly detect your sensors:

sudo sensors-detect

Follow the suggestions, accept the defaults if it's "safe" and skip anything that "could be risky".

more: how-to-use-to-use-lm-sensors

If you want control over your CPU you can install a frequency scaler:

sudo apt-get install indicator-cpufreq

You may have to search for it in your apps to enable it the first time. I couldn't get it to run on any pentium4 computers but if your celeron is supported, you'll probably appreciate the direct control.

Finally, look into installing some openGL support. Windows has activeX but linux has openGL to provide hardware acceleration to reduce the load on your CPU by enabling your GPU to do it's job. There is also a intel-linux-graphics-installer available that can keep you up to date with the latest opensource intel firmware. 01.org/linuxgraphics/downloads

| improve this answer | |
  • 1
    Also if you wish to add to your answer the terminal command top will show very detailed CPU usage statistics, the OP should run this command and see which prosses is causing the CPU spike – Mark Kirby Aug 25 '14 at 9:07
0

According to the hp web site http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/action.process/public/psi/learnUseDisplay/?sp4ts.oid=373069&javax.portlet.action=true&spf_p.tpst=psiContentDisplay&javax.portlet.begCacheTok=com.vignette.cachetoken&spf_p.prp_psiContentDisplay=wsrp-interactionState%3DdocId%253Demr_na-c03730053%257CdocLocale%253Den_US&javax.portlet.endCacheTok=com.vignette.cachetoken

Your machine has 3d video hardware (ATI Mobility Radeon 4X AGP 3D), this can be used to speed up the desktop (drawing/moving windows and the mouse etc), and free up the cpu for other tasks.

I have no idea how to enable it (I use Debian7 with kde). However I can tell you it makes a big difference on my Celeron(R) Dual-Core CPU T3000 @ 1.80GHz

| improve this answer | |
  • You should be able to install gnome or kde or even unity (if you like that sort of thing), without having to reinstall everything. – ctrl-alt-delor Aug 25 '14 at 11:39
0

Your problem is probably some hardware component not being detected, initialized, & used.

1: Update to the newest Lubuntu.

2: Update Lubuntu drivers.

3: Problem fixed? Great!

If still having a problem:

1: Download Lubuntu 9 (Still supports older hardware).

2: Update drivers.

3: Problem fixed?

Still having problems?

Try Xubuntu.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.