5

I've installed Ubuntu 14.04 and later installed Mate desktop environment. I did not like it and wanted to switch back to Ubuntu Unity. I removed Mate Desktop from the system also. But I have several issues.

  • Loading screen while booting shows Ubuntu-Mate background.
  • Login screen still the same as of Mate
  • 2 Network icons at top bar

enter image description here

  • Little slower than before to load the whole desktop after pressing putting password on login screen.

Please help me get back to original Ubuntu.

Edit

Followed the following link to install it.

http://www.omgubuntu.co.uk/2014/08/install-mate-desktop-ubuntu-14-04-lts

sudo apt-add-repository ppa:ubuntu-mate-dev/ppa
sudo apt-add-repository ppa:ubuntu-mate-dev/trusty-mate
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install --no-install-recommends ubuntu-mate-core ubuntu-mate-desktop

And then just switched back using the option in login page (choosing the desired desktop env). After I see loading pages are still Mate based, I tried to remove ..

sudo apt-get remove ubuntu-mate-core ubuntu-mate-desktop

still same login page and loading page, then tried changing display manager to lighdm

sudo apt-get install lightdm

and choosing the default as lightdm

and tried

sudo apt-get install ubuntu-desktop

Still no luck. :(

  • Since mate is not incluided in Ubuntu 12.04 repositories you could start by editing your question and detail how you installed it in the first place and how you removed it. – xangua Aug 25 '14 at 6:01
  • @xangua, yes, I have included the steps. – BlueBird Aug 25 '14 at 6:11
5

Please try this command to fully remove the desktop

sudo apt-get remove --purge ubuntu-mate-core ubuntu-mate-desktop

If you have both GDM and lightDM installed please

sudo apt-get remove --purge gdm

Then set light dm to default (use the method you said you use before)

Based on mchids comment below this, you need to edit edit this file 50-unity-greeter.conf

Create a 50-unity-greeter.conf

sudo gedit /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

The file this opens should be blank so add this to it

[SeatDefaults]
greeter-session=unity-greeter

Save it then

sudo chmod +x /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Then reboot and see if this helps

TO FIX YOUR ICONS

An easy fix for your icons should be install unity tweaktool from software center (dont know package name for apt, maby someone will edit)

Go to icons and just choose different ones

  • splash screen & the one asking for choosing username and enter password – BlueBird Aug 25 '14 at 7:18
  • Did you try this solution and mchid's solutions,for the log in screen ? Lets fix this first then we can do the splash – Mark Kirby Aug 25 '14 at 7:22
  • How can dual icon be fixed with Ubuntu tweak by selecting different icon set? – Anwar Dec 11 '14 at 15:33
3

To fix the login screen:

Run the following two commands in an open terminal:

echo "[SeatDefaults]" | sudo tee /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf
echo "greeter-session=unity-greeter" | sudo tee -a /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Finally, use this command to make the file executable:

sudo chmod +x /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Save any unsaved work and reboot for the changes to take effect. Login screen is now fixed.


To remove the mate network-manager indicator from the unity-panel (and most of the other mate packages)

run the following command:

sudo apt-get purge mate* ubuntu-mate*

This should also fix the problem with the splash screen.


To remove the ppa(s), run the following commands:

sudo rm /etc/apt/sources.list.d/ubuntu-mate-dev-ppa-trusty.list*
sudo rm /etc/apt/sources.list.d/ubuntu-mate-dev-trusty-mate-trusty.list*

Finally, update your package list and apply any upgrades with the following commands:

sudo apt-get update
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get upgrade
1

To fix the login screen:

create new lighdm configuration file:

sudo gedit /etc/lightdm/lightdm.conf

Add the following lines in this file:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Save and reboot.

To fix two network indicator in top panel:

cd /etc/xdg/autostart
sudo rm *mate*

Reboot.

You can follow the complete tutorial which I wrote to install and uninstall Mate in Ubuntu 14.04.

  • Did you test the solution for dual icons? Actually you only need to disable the autostart of nm-applet-mate.desktop file – Anwar Dec 11 '14 at 15:43
1

for ubuntu 14.04 LTS

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ubuntu-mate-dev/ppa
sudo ppa-purge ppa:ubuntu-mate-dev/trusty-mate
sudo apt-get remove mate-*
sudo apt-get autoremove
cd /etc/xdg/autostart
sudo rm *mate*
sudo apt-get remove --purge lightdm-gtk-greeter
rm -f /etc/lightdm/lightdm-gtk-greeter.conf
rm -rf /usr/share/lightdm-gtk-greeter.conf
rm -f /usr/share/lightdm/lightdm-gtk-greeter.conf
1

Also, ubuntu-mate-desktop changes your splash screens. To revert that, I had to change it via plymouth.

To do this on Ubuntu 16.04, you would execute the following commands:

cd /usr/share/plymouth/themes/
sudo update-alternatives --config default.plymouth

And then use the menu which came up to select /usr/share/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth. If you can't find the directory /usr/share/plymouth/themes/ then check /lib/plymouth/themes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.