5

I just upgraded from Ubuntu 12.04 to 14.04. After upgrading the terminal will sometimes, but not always, flash between the current screen and the previous screen. Here are some examples:

  1. The output of an 'ls' command will flash on and off the screen.
  2. But when I press enter to start a new line, sometimes--but not always--the output of ls will stop flashing and instead the newline will begin flashing.
  3. Sometimes vim will start flashing between the current place and a previous place, such as right after a search.
  4. This also happens when I opened just sh within a bash terminal. (I was hoping the issue was just with my .bashrc, though I haven't changed it in months and didn't have any issues in 12.04.)

This is incredibly annoying, and has made the terminal essentially unusable.Unfortunately, google-ing for a half hour hasn't shown anyone running into similar problems, either on 14.04, other versions of ubuntu,or other versions of linux.

UPDATE: I'm not sure if this helps identify the problem, but the text stopped blinking when I turned the cursor blinking off using these instructions How do I disable the blinking cursor in gnome-terminal?. However the problem isn't totally fixed because now the text will disappear for a moment when I type.

  • I have this exact problem too.. I have tried all kinds of things. At some point I thought that it had something to do with the NVidia card I am using, but the problems are only in the terminal. So I doubt it. I am using Gnome terminal 3.6.2 using zsh 5.0.2 and usually tmux. The flashing occurs outside of tmux as well, however. This is a really annoying problem, as I use the terminal a lot, for Javascript in development in VIM mostly, and git. It seems to me that the problem is related to Gnome terminal. I have switched to Sakura and have so far been flash free. – FHoffmeyer Aug 30 '14 at 14:00
  • I have this problem too, but using Sakura didn't fix it. I also have an NVidia card, terminal 3.6.2, zsh 5.0.5, and no tmux. – jkff Oct 8 '14 at 0:18
  • This problem seems to occur (for me at least) in both gnome-terminal and guake, so it might not be terminal-specific. – Nate Kohl Oct 15 '14 at 16:45
  • (I also tried Sakura as posted above, but it didn't help.) – Nate Kohl Oct 15 '14 at 17:29
5

It's possible this is a compiz/nvidia bug.

I noticed very similar "screen flashing" that seemed tied to screen redraws, e.g. chunks of the screen would redraw strangely as the cursor blinked, or if I turned off the blinking cursor, would just fail to redraw at the right time.

https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1314367/ describes the following workaround:

To fix it, you get CompizConfig Settings Manager (ccsm) and you go down to "Workarounds" in the "Utility" Category and check the box that says "Force full screen redraws (buffer swap) on repaint".

...which seems to have worked for me. At least for now.

| improve this answer | |
0

Many years later I've started getting this same issue after upgrading from Ubuntu 18.04 to Ubuntu 20.04. It's happening with Regolith desktop and gnome terminal located at /usr/bin/x-terminal-emulator.

Fixed by installing the old st terminal with apt install stterm and then changing my ~/.config/regolith/i3/config file to launch /usr/bin/st when pressing $mod+Return instead of x-terminal-emulator.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.