1

I've upgraded from dual-booting Ubuntu 12.04 LTS / Windows 7 to dual-booting Ubuntu 14.04 LTS / Windows 7.

Before the upgrade, when booting Ubuntu, the login window would appear as expected, waiting for my password. But after upgrading, the login window appears for less than 1 sec (on a solid purple background with a grid of dots) before getting "covered over" by a multicolored wallpaper that says "14.04 LTS" in the lower left corner.

From this point I can get to the desktop either by entering my password "blindly" (with invisible login window), or I can make the login window visible again by moving the mouse a few inches to the right. (The mouse pointer behaves as though it's initially off the left edge of the screen.)

Q: What can I do to prevent the login window from getting hidden in the first place?

UPDATE: In case this might be relevant ...

dir /etc/lightdm -->

lightdm.conf
lightdm.conf~
lightdm-gtk-greeter.conf
lightdm-gtk-greeter-ubuntu.conf
users.conf

and

cat /etc/lightdm/lightdm.conf -->

[SeatDefaults]
greeter-session = unity-greeter
user-session = ubuntu
allow-guest = false 

Per the answer by Xieerqi, replacing greeter-session = unity-greeter with greeter-session = lightdm-gtk-greeter is a viable workaround, but does not solve the issue with unity-greeter. Since one of the links in that answer refers to lightdm-unity-greeter (i.e., with the prefix lightdm-), I also tried the line greeter-session = lightdm-unity-greeter, without success.

2

The login screen is called greeter in Ubuntu. While I can't think of exact fix, I can suggest a work-around. Basic idea is changing the greeter. Now, depending on which desktop manager program you are using , the configuration settings will be different. I assume you have lightdm manager, which is default that comes with Ubuntu. Here's procedure for replacing lightdm's default unity greeter with lightdm-gtk-greeter.

  1. When Ubuntu starts and gets to login screen, press Ctrl+Alt+F2 to get to tty terminal screen. Login with your user name and password.
  2. Enter the following command sudo apt-get install lightdm-gtk-greeter , it will prompt you for password, and after you enter, it will run a bunch of commands, asking also if the size of installation is okay. This will install the lightdm-gtk-greeter on your machine.
  3. After installation is done, we need to alter lightdm's settings so that the default greeter is replaced with lightdm-gtk-greeter. Still in the terminal window enter sudo nano /etc/lightdm/lightdm.conf . This will open configuration file lightdm.conf in the Nano command line text editor(very useful app, by the way).
  4. Add the following line to this file greeter-session=lightdm-gtk-greeter ; Press Ctrl+O, it will prompt you for file name to write, don't change file name - just press enter. Once it says wrote, press Ctrl+X to exit.
  5. Now the settings have been changed. Reboot the computer using this command sudo shutdown -r now and the window for username and password should be placed in the center of the screen now, which is how gtk greeter normally looks.

This procedure works for a variety of other greeters. However if you have different desktop environment, like gdm, the procedure will be slightly different, but the main premise is the same - entering command line,downloading proper greeter, altering configuration files, reboot. I've listed additional information and links bellow. Let me know if that helps. Cheers !

Sources: archwiki , askubuntu.com, ubuntu wiki, and some personal experience messing with lightdm settings;

Bonus : here's some of my favorite command line apps in case GUI stuff doesn't work or you can't log into graphical shell

  1. Midnight Commander - file manager; sudo apt-get install mc
  2. elinks command-line web browser; sudo apt-get install elinks
  3. moc command line music player; sudo apt-get install moc and mocp to actually run it;
  • Thanks for the all the useful details. After steps 1-5, I'm now happily using lightdm-gtk-greeter. (Still, it would be satisfying to know how to fix whatever was going on with unity-greeter.) I'll definitely take a look at the apps you mention. – r.e.s. Aug 25 '14 at 4:27
  • BTW ... When I first edited lightdm.conf, I inadvertently put a single space at the end of the line greeter-session=lightdm-gtk-greeter. Amazingly, this resulted in no greeter at all, so I repeatedly logged in using Ctrl-Alt-F2 (which I hadn't known about til now) until eventually finding that the problem was just that single space. – r.e.s. Aug 25 '14 at 5:22
  • That's one of the annoying parts about configuration files and scripting - unix/linux command line hates spaces. As for unity greeter , there's some other config files which you could investigate. Look through some of the links I added in source part. I will post a bit later copies of how my config file for unity look like. Right now I'm on mobile so haven't access to those – Sergiy Kolodyazhnyy Aug 25 '14 at 6:29
  • Hello again, friend ! I apologize for late reply. So I've thought a bit about unity greeter, and I think the best bet to fix unity greeter is to reinstall it. This can be accomplished with the command : sudo apt-get install --reinstall unity-greeter. See if that helps. And you do already know how to change greeters, too, so should be piece of cake, right? – Sergiy Kolodyazhnyy Aug 27 '14 at 6:35
  • I reinstalled unity greeter per your advice, but it seems to have had no effect. The login window still gets hidden by the multicolored wallpaper -- which looks the same as the default desktop wallpaper, except it has "Ubuntu 14.04 LTS" in the lower left corner, and has a large version of the circular Ubuntu logo in the center of the screen. (I turned off the grid of dots using Ubuntu Tweak.) – r.e.s. Aug 27 '14 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.