1

I read and followed easy install instructions for sharing files with Ubuntu.

I have three computers, Windows 7 64-bit home premium, Windows Vista and Ubuntu 14.04 LTS.

My problem is that I cant access Ubuntu. When I open Explorer, go to Network, I can see all three computers but as soon as I click on Ubuntu box appears. It says :

Windows cannot access \ ( my computer name here ) ...

What should I do ?

  • 3
    Did you install SAMBA on your Ubuntu box? – Jan Aug 24 '14 at 16:53
  • You may need to reboot the Ubuntu machine. You may also try the sudo net usershare list command to list the defined shares. – mikewhatever Aug 24 '14 at 17:29
  • Thanks. I tried it but didnt work. – John Wayne Aug 25 '14 at 13:03
  • See askubuntu.com/questions/310180/… – user68186 Aug 25 '14 at 13:39
1

probably you don't have any user configured in smb.conf and/or your workgroup is not defined correctly.

  1. Edit smb.conf with gedit or nano

    sudo nano /etc/samba/smb.conf

  2. Edit or Add workgroup, in Windows as default is: WORKGROUP

    workgroup = WORKGROUP

  3. Check if are directories to share declared in smb.conf

find a structure like this:

[folder_name_in_windows]
 comment = comment
 path = /home/public
 public = yes
 writable = no
  1. Add user to SMB via shell after create an Ubuntu user without privileges and with your_user name.

    sudo smbpasswd -a your_user

Then, enter password or hit Enter to create the user without password.

Hope this can help you.

  • Thanks for your help. I tried all your tips but I still have the same problem. "Windows cannot access \\..." – John Wayne Aug 25 '14 at 13:04
  • Sorry I forget that you need create the user in Ubuntu after ` sudo smbpasswd -a your_user` The user and password must be the same in Ubuntu and Samba. Try this and let me know. – makgyverzx Aug 25 '14 at 13:35
  • I dont know so much about these things. Can you tell me how to create user in ubuntu ? – John Wayne Aug 25 '14 at 14:36
  • Sure sudo adduser desired_username and ask questions about Real Name and password – makgyverzx Aug 25 '14 at 14:39
  • 1
    Guys, I installed ubuntu again and followed your instructions. Now its working. Thanks for everyone 👍 – John Wayne Aug 26 '14 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.