5

I have a freshly installed Lubuntu 14.04.1 (installed with forcepae option on a laptop with Pentium M processor). The only problem that I have found so far is that I cannot shut-down or restart the laptop. It always continues showing "Lubuntu" and some dots. Pressing Esc it says

wait-for-state stop/waiting
* Stopping rsync daemon rsync                                         [OK]
* Asking all remaining processes to terminate…                        [OK]
* Killing all remaining processes…                                    [fail]
ModemManager [597] :  <info>  Caught signal, shutting down…

ModemManager [597] :  <info>  ModemManager is shut down

nm-dispatcher.action: Could not get the system bus. Make sure the message bus daemon is running!  Message: Did not receive a reply.  Possible causes: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
* Deactivating swap…                                                  [OK]
* Will now halt

The cursor remains blinking but the only way to switch it off is to hold the power-off key pressed for some seconds.

I tried sudo shutdown -h now, sudo halt and sudo poweroff resulting in the same problem.

I also tried to add acpi=force in GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" in /etc/default/grub and run sudo update-grub; then, using the taskbar's shot-down button lead to a direct stop of the laptop equal to holding the power-off key pressed for some seconds.

Next I followed the answer https://askubuntu.com/a/202481/288322. Now, I directly receive some messages during shut-down starting

wait-for-state stop/waiting
* Stopping rsync daemon rsync                                         [OK]
* Asking all remaining processes to terminate…                        [OK]
[ 240.944277] INFO: task kworker/0:2:24: block for more than 120 seconds.
[ 240.944461]       Tainted: G S            3.13.0-34-generic #60-Ubuntu
[ 240.944623] "echo 0 > /proc/sys/kernel/hung_tasks_timeout_secs" disables this message.

followed by some more similar lines and then:

* Killing all remaining processes…                                    [fail]
ModemManager [576] :  <info>  Caught signal, shutting down…

nm-dispatcher.action: Caught signal 15, shutting down...
ModemManager [576] :  <info>  ModemManager is shut down

* Deactivating swap…                                                  [OK]
* Will now halt

[ 600.944276] INFO: task kworker/0:2:24: block for more than 120 seconds.
[ 600.944458]       Tainted: G S            3.13.0-34-generic #60-Ubuntu
[ 600.944619] "echo 0 > /proc/sys/kernel/hung_tasks_timeout_secs" disables this message.

Then, nothing more was coming during the next 5 minutes.

If you know where can I find relevant error information, I will be happy to search for them.

Following the advice below (@mintyfreshpenguin, https://askubuntu.com/a/515799/288322), i.e. using sudo halt -p leads to a similar messages during shut-down:

wait-for-state stop/waiting
* Stopping rsync daemon rsync                                         [OK]
* Asking all remaining processes to terminate…                        [OK]
* Killing all remaining processes…                                    [fail]
ModemManager [564] :  <warn>  Could not acquire the 'org.freedesktop.ModemManager1' service name

nm-dispatcher.action: Caught signal 15, shutting down...
ModemManager [564] :  <info>  ModemManager is shut down

* Deactivating swap…                                                  [OK]
* Will now halt
[ 240.828234] INFO: task kworker/0:0:4 blocked for more than 120 seconds.
[ 240.944461]       Tainted: G S            3.13.0-34-generic #60-Ubuntu
[ 240.944623] "echo 0 > /proc/sys/kernel/hung_tasks_timeout_secs" disables this message.

The last message [ 240.xxxxxx] INFO: is repeated for:

  • task upowerd:1352
  • task halt:2081
  • task kworker:0:0:4

for [360.xxxxxx], [480.xxxxxx], [600.xxxxxx] and perhaps even longer, but after [600.xxxxxx] INFO: task kworker/0:0:4 blocked for more than 120 seconds came no more message for 10 minutes and I pressed the power-off button for some seconds.

Update Lubuntu 18.04

After using Debian with an older kernel for a while, I now switched back to Lubuntu 18.04.1. The shut-down is working better, but still not properly. Now, the last three lines that are shown when pressing ESC directly at the beginning of the shut-down process are

[OK] Reached target Shutdown.
[OK] Reached target Final Step.
     Starting Power-Off...

Then, nothing happens any more and I have to press the power-off button for some seconds to completely switch off the laptop.

Starting a shut-down log*, I found that the system tries to mount the hard drive again (EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro). I asked for help on this in https://askubuntu.com/a/563671/288322 and will "report" in case the problem can be solved.

*) As described in the "Debugging boot/shutdown problems" section of /usr/share/doc/systemd/README.Debian.gz (instruction found in https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1464917 provided by https://askubuntu.com/a/668695/288322).

Update February 2020

Since the last regular update (February 2020), shut down works just fine :) Try Lubuntu 18.04.4 if you experience the described problems.

4
  • i had the same Problem but this link fixed the problem: hecticgeek.com/2012/10/speed-up-ubuntu-shutdown-process
    – user329872
    Sep 23 '14 at 20:55
  • 1
    I am facing the same problem now and am dismayed that this is considered off-topic. I wonder what an on-topic question will look like. What a shame there is no working answer!
    – chandra
    Dec 31 '14 at 19:25
  • This link helped me and might help someone else: kubuntuforums.net/…
    – chandra
    Jan 1 '15 at 2:18
  • the message says to run echo "0" | sudo tee /proc/sys/kernel/hung_tasks_timeout_secs to skip the 120 second block on kworker.
    – mchid
    Mar 15 '15 at 13:55
1

I've been holding off offering an answer to your question. I'm not sure if I've got the wrong end of the stick (so to speak). Your question reminds me of a similar scenario I found myself in a few years back. If you already know what I'm about to tell you. Then please accept my apologises I do not wish to patronise.

The output you have provided clearly shows there is something going slightly wrong during the shut down process. It looks as though the modem manager isn't exiting as cleanly as perhaps it should. But the system is recovering by forcing the process to end. The final message you get “Will now halt” confirms the system is halted.

The cursor remains blinking but the only way to switch it off is to hold the power-off key pressed for some seconds.

I tried sudo shutdown -h now, sudo halt and sudo poweroff resulting in the same problem.

Now this is the bit that reminds me of my scenario a few years back. I had exactly the same problem running an Ubuntu Server with no gui. I spent sometime researching the problem. If I remember correctly the fault was simply that the system was not sending the mobo poweroff signal. I'm fairly sure at the time there was an open bug recorded for the issue. Anyway, the workaround I found was to pass the power off flag to the halt command:-

sudo halt -p

using the taskbar's shot-down button lead to a direct stop of the laptop equal to holding the power-off key pressed for some seconds.

Can you provide more details for this part? Watch closely, try to see if the system is shutting down cleanly albeit very quickly. Or is it just stopping in it's tracks quite literally as though the power was ripped out. Press esc key to remove the dots and see what is being reported in the text output. Sometimes a camera is handy to catch fast moving text as it scrolls by.

I ask because my Xubuntu media PC (as with most of my Linux boxes) shuts down sooooo fast it often looks as though the power has been ripped out. This is one area I struggled with when I first moved from Windows. It was a case of click shutdown and boom the Linux system was gone. None of the “looging off” and “Do not power off your system installing 1 of 90000 updates” messages.

Anyway like I said I do not wish to patronise, if you already knew this please except my apology . It is hard to judge someone's experience level when conversing by text only.

1
  • I added the output of what happens using sudo halt -p in the question. Clarification: Using the taskbar's shot-down button lead to a direct stop of the laptop equal to holding the power-off key pressed for some seconds if (and only if) I added acpi=force in GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" in /etc/default/grub and run sudo update-grub. Here, shut-down was immediately without any more messages as though power supply was interrupted.
    – Rantanplan
    Aug 25 '14 at 15:45
0

You can generally shut down your computer by holding down Alt and Prt Sc and then slowly pressing REISUB in that order. It works on most computers. It is not good for your hardware to force a shut down by pressing the power button.

1
  • Your hint works, but it does not shutdown the laptop in the "usual" way but exactly as immediately as keeping the power button pressed for some seconds. After that, it restarts automatically. I am looking for the "usual" shutdown.
    – Rantanplan
    Aug 25 '14 at 9:45
0

I'm researching this problem on an Intel NUC DE3815TYKE/H with Lubuntu 14.04 installed on the internal 4GB eMMC. I've already run the software updater.

My current theory is that, as one cogent forum user advised me to forgo a swap partition (due to installing on flash-based media,) the system is looking for (& not finding) that swap-space during the shutdown process.

Is anyone else who is experiencing this problem also running from an SSD or other flash-based media?

Currently editing /etc/rc0.d/S40umountfs & (as I have no swap partition,) commenting out the following lines:

#
# Deactivate swap
#
#   if [ "$VERBOSE" = no ]
#   then
#       log_action_begin_msg "Deactivating swap"
#       swapoff -a >/dev/null
#       log_action_end_msg $?
#   else
#       log_daemon_msg "Will now deactivate swap"
#       swapoff -a -v
#       log_end_msg $?
#   fi

Will return to report upon results...

Ok, this did not seem to work. Now hanging up on "System will now restart". Will keep looking...

Not the answer you're looking for? Browse other questions tagged or ask your own question.