4

I get errors for all these commands when I try to use vim (though vim then works):

autocmd BufWritePre *.rb :%s/\s\+$//e
set filetype off
filetype plugin on
filetype indent on
syntax on " Turn on syntax highlighting
match ExtraWhitespace /\s\+$/
autocmd BufWinEnter * match ExtraWhitespace /\s\+$/
autocmd InsertEnter * match ExtraWhitespace /\s\+\%#\@<!$/
autocmd InsertLeave * match ExtraWhitespace /\s\+$/
autocmd BufWinLeave * call clearmatches()
let mapleader = ","
set foldmethod=indent   "fold based on indent
set foldnestmax=10      "deepest fold is 10 levels
set nofoldenable        "dont fold by default
set foldlevel=1         "what I use
let loaded_matchparen = 1 " MDD Turn off matching bracket " Ubuntu14 filetype plugin indent on    " required

If I comment these lines out in my .vimrc I don't get any errors.

But I suspect I may have now 'lost' those settings.

Is there a different form for them or something in vim in Ubuntu 13?

Errors:

Three categories:

  • Sorry, the command is not available in this version
  • Option not supported
  • Unknown option

Details:

$ vi .vimrc
Error detected while processing /home/durrantm/.vimrc:
line   20:
E319: Sorry, the command is not available in this version: autocmd BufWritePre *.rb :%s/\s\+$//e
line   24:
E519: Option not supported: filetype 
line   25:
E319: Sorry, the command is not available in this version: filetype plugin on
line   26:
E319: Sorry, the command is not available in this version: filetype indent on
line   27:
E319: Sorry, the command is not available in this version: syntax on " Turn on syntax highlighting
line   37:
E319: Sorry, the command is not available in this version: match ExtraWhitespace /\s\+$/
line   38:
E319: Sorry, the command is not available in this version: autocmd BufWinEnter * match ExtraWhitespace /\s\+$/
line   39:
E319: Sorry, the command is not available in this version: autocmd InsertEnter * match ExtraWhitespace /\s\+\%#\@
<!$/
line   40:
E319: Sorry, the command is not available in this version: autocmd InsertLeave * match ExtraWhitespace /\s\+$/
line   41:
E319: Sorry, the command is not available in this version: autocmd BufWinLeave * call clearmatches()
line   48:
E319: Sorry, the command is not available in this version: let mapleader = ","
line   52:
E518: Unknown option: foldmethod=indent
line   53:
E518: Unknown option: foldnestmax=10
line   54:
E518: Unknown option: nofoldenable
line   55:
E518: Unknown option: foldlevel=1
line   57:
E319: Sorry, the command is not available in this version: let loaded_matchparen = 1 " MDD Turn off matching brac
ket highlighting.
line   58:
E319: Sorry, the command is not available in this version: filetype plugin indent on
3
  • 1
    I cannot check it right now, but in general you should not expect that vi is Vim. It may be true for Ubuntu 13.10 and untrue for 14.04. Use $ vim. Aug 23, 2014 at 18:56
  • 1
    Did you do set nocompatible before all the other options?
    – muru
    Aug 23, 2014 at 19:21
  • 1
    Dmitry. Good call. Turns out I had dependency issues and vim wasn't usable. Posting my answer for others. Aug 24, 2014 at 12:07

1 Answer 1

5

Turns out I didn't have vim, just had vi, due to dependency issues after the upgrade.

tl;dr; - needed older versions of dependencies. Fixed with:

$ sudo apt-get remove vim-common 
$ sudo apt-get remove vim-runtime
$ sudo apt-get update && sudo apt-get install vim  
Change .vimrc setting "set filetype off" => "filetype off"

Full Version...

Fix was:

Attempted to do:

apt-get install vim

But got message

...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vim : Depends: vim-common (= 2:7.4.052-1ubuntu3) but 2:7.4.335-1~ppa1~s is to be installed
       Depends: vim-runtime (= 2:7.4.052-1ubuntu3) but 2:7.4.335-1~ppa1~s is to be installed
E: Unable to correct problems, you have held broken packages.
$

So then I tried:

$ sudo apt-get install vim-common

Reading package lists... Done
Building dependency tree       
Reading state information... Done
vim-common is already the newest version.

Finally, realizing that the messages say the dependency is 2:7.4.052 but I have 2:7.4.335 for vim-common and vim-runtime, in other words I had more recent versions. Realizing this the final fix was:

$ sudo apt-get remove vim-common 
...
$ sudo apt-get remove vim-runtime

Then I was able to do;

$ sudo apt-get update && sudo apt-get install vim  

This fixed all the issues except for one line

set filetype off

which I changed to

filetype off

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.