When using drag and drop the launcher bar reveals and will not hide unless I close the program.

Is their a fix?

  • will you please explain what actually happened? – shantanu Jul 2 '11 at 10:27
  • @shantanu I face the same issue when running java based programs, Such as Netbeans. If one of the windows (in netbeans e.g.output, tasks) dragged this is a sure thing to happen. This happened with LibreOffice - Draw but i couldn't reproduce it. Dragging other component of a program e.g firefox tab or desktop icon do solve the matter – Niroshan Jul 30 '11 at 19:11

Run this in a Terminal (Ctrl+Alt+T):

unity --replace

That works for me on Ubuntu 12.04.

  • BEWARE! This worked for me, but crashed a number of running applications, including firefox. – Scott Dec 15 '17 at 15:37

Drag a desktop icon a bit.

Helps against the stuck launcher bar with Opera on a 32-bit system. Another solution would be to set the launcher not to hide in the first place (that's my solution for now). See How can I configure Unity's launcher auto-hide behavior?

There are also bug reports:

  • Opera: bug 741731 (note the "Won't Fix" as it's a bug in Opera)
  • Another one - not sure what's the actual status on this one.
  • I ran into the "not hiding anymore" Unity/Gnome Ubuntu dock/launcher as well and found this answer here to be really helpful: just move one of the icons on the launcher a bit - that seems to reset autohide. At least for me, the Unity-dock resumed autohide afterwards. (I don't know why the dock autohide stopped in the first place, could be some hibernation cycles..) – isync Oct 13 '13 at 12:11

I ran into the same issue on 14.04. It seems this can happen with the four-finger slide gesture. If this is the case, simply do a four-finger slide to the left to slide the bar back into place.

  • works on 16.04! – user540997 Nov 14 '17 at 15:40

Its not uncommon for the launcher to get stuck. Opening the dash with the Super Key seems to fix it for me and its way better than killing a program.

If you can reproduce it, you might want to post a bug report.


Same problem when using Netbeans (Java) : when I drag tabs to reorganize them, the launcher appears and gets stuck (ie wont hide anymore). Could not fix the problem, but found 2 solutions : - drag and drop Firefox tabs around - drag something to the laucher


I had the same problem after I moved icons around and opened the dash with the super key. I simply logged out then logged back it. Fixed it right up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.