7

I'm using Ubuntu 14.04. Now I installed Grails via the gvm tool. I also tested it and created a demo app via the comandline and all works fine. But the big problem is, IntelliJ can't find the Grails lib. The home variables are set.

I had Groovy installed via apt so IntelliJ could find it. But via the gvm not. What's wrong there?

5

Grails is located in your home folder's .gvm/grails. Go to your home folder from intelliJ and right click it, you will have the option to show hidden folder's. There you will find .gvm/grails. You can point intelliJ to the current folder located there which is the symbolic link to whichever grails you make default using gvm or you can point to any grails version you like.

Hope this helps.

1

I had the same problem with version 15 IntelliJ after upgrading on OS Linux Ubuntu 12.04

I found that because the Android SDK wasn't in the home folder of the user running IntelliJ that you had to change the Folder/file permissions before it would see this

Mine was in the root

Issuing the command chown -R /path/to/android_sdk_dir solved the problem for me

If this fails after doing this delete the ~/.ideaC(Lastversion number) any previous ~/.ideaC(Lastversion numbers) folder's and then re open intelliJ

You will have to go through the initialization of the IDE and give the path to your Java installation ver8 upwards only on intelliJ version15 and there after your android sdk installation

I found this can also cause conflicts

As a further tip add the following to the very end of your ~/.bashrc using one of your editors (nano , vi etc )

Example vi ~/.bashrc

The following lines set the Android Path

PATH=$PATH:/path/to/android/:/path/to/android/tools
export PATH

For SDK version r_08 and higher, also add these two lines for adb:

PATH=$PATH:/path/to/android/platform-tools
export PATH

for setting android emulator to 32 bit version add this line

export ANDROID_EMULATOR_FORCE_32BIT=true

Exit your choice of editor (vi, nano, etc ) saving your bashrc file then source .bashrc with the command below

source ~/.bashrc

Hope that helps you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.