I'm trying to configure my virtual machine so I can share a folder between my host and guest OS, but when I try to install the Guest Additions I get the following message: enter image description here

I've already done everything that is describe on: VirtualBox Guest Additions won't install on Ubuntu Server 12.04

but it's still not working.

[SOLUTION] As said in the comments, all I had to do was install the newest version. After that, it worked perfectly.

  • One of the things suggested in the linked question is "uninstall VirtualBox & install the latest version". Virtualbox 4.1.12 is older than the oldest version of Ubuntu 12.04. Installing a newer version may work better. And make sure the kernel header files are really installed. Aug 22, 2014 at 21:00
  • I've installed the newest version and it's now working perfectly. Thanks!
    – romaolucas
    Aug 25, 2014 at 19:41

2 Answers 2


Instead of installing the guest additions from virtualbox's virtual CD, you can try installing the pre-built Ubuntu package. Just:

sudo apt-get install virtualbox-guest-dkms

this will compile and install the required module and enable folder sharing, shared clipboards and resizable display with seamless pointer integration.

If you want to continue doing it the hard way:

  1. The message on your screen clearly indicates a log file you can look at to get more details about the problem.
  2. I'm pretty sure this is because you don't have the appropriate development tools and kernel headers installed. You can do this to install them, then retry your process:

    sudo apt-get install linux-headers-$(uname -r) build-essential

  • I've already installed the pre-build package and the kernel headers. I'm going to edit my post and put my log message.
    – romaolucas
    Aug 25, 2014 at 17:47
  • this did it for me! Nov 12, 2014 at 3:39
  • Amazing! Works for me !!
    – laike9m
    Apr 28, 2015 at 8:45
  • @roadmr - Tried your suggestion. Everything seems to work fine, but error msg "unknown filesystem type vboxfs" still appears, even after rebooting the guest. What am I supposed to do to start the GuestAdditions service after running your sudo command? By the way, linux headers build-essential are OK Sep 4, 2016 at 7:42

It's not the CDRom thats the problem - your system is complaining that you do not have the current linux headers required to build the module.

Try the following command from a terminal:

sudo apt-get install build-essential linux-headers-`uname -r`

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .