22

This question already has an answer here:

How can I make programs open in the foreground? Nautilus will open in the background, Remmina (the remote desktop program) also opens in the background. I have to click on the icon in the Launcher for it to come to the foreground. I would think any program that is invoked by any means would come to front, as it opens. It seems if one program invokes another, it will be in the background. If I click on any icons in the Launcher though, it will actually open in the foreground.

marked as duplicate by wjandrea, user364819, Sumeet Deshmukh, David Foerster, Zanna Jun 16 '17 at 5:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

21

First install CCSM

sudo apt-get update
sudo apt-get install compizconfig-settings-manager

Then run ccsm. Under -> General -> General Options -> Focus & Raise Behaviour -> You will find: "Focus Prevention Level" set it to "Off"

  • why? because that is how they made it to work. The user isn't looking for why, they are looking for how to make the windows appear in the foreground. – Mateo Jan 30 at 16:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.