This is the most frustrating issue I have ever run into using Ubuntu and Windows in the same machine.

I have an ASUS K46CB, 6GB RAM and preinstalled Windows 8.1 64-bits. I have successfully installed Ubuntu 14.04 LTS, also 64-bits. To do so,I followed this tutorial whenever possible. I only failed on the disable secure boot part: there is no 'Secure-boot' or even UEFI mention in my BIOS!

Screenshots from other BIOS of the same model show the option under Boot, but in mine there is absolutely none. Because of this, I cannot boot into Ubuntu. The computer loads straight into Windows.

I tried running boot repair, but got an error (i can show the log, but it's pretty long).

Does anyone know how to fix this issue?


I reinstalled Ubuntu. Same problem, goes straight to Window. Boot-Repair informs me that i am using Windows in Legacy mode. It excecuted with no errors this time, but after restarting GRUB was still missing. I can't turn off Secure Boot yet.


I tried using Boot Repair to install grub on a bios-grub 1mb partition. Still boots straight to windows. I feel like punching something

UPDATE I reinstalled Ubuntu with a bios-grub partition again, no luck. I forgot to add, there is also no Ubuntu boot option in the BIOS. Even though the OS is installed, I simply cannot access it.

I'm becoming very worried about this, I need Ubuntu for college, does anyone have any ideas on how to fix this??

  • Some have simple UEFI and just turning on BIOS/CSM/Legacy mode means secure boot off. Then system boots with UEFI if found or with BIOS if found. If Ubuntu is in BIOS Mode you can only dual boot from UEFI/BIOS menu and may have to turn on/off UEFI or BIOS settings. Some auto switch and you can use one time boot key, possibly f12 but varies by vendor. – oldfred Aug 21 '14 at 21:48
  • @oldfred should I reinstall Ubuntu again in non-UEFI (Legacy?) mode? if so, do you know how to do it? edit: based on this page (help.ubuntu.com/community/UEFI#Installing_Ubuntu_in_EFI_mode), I think I already installed the Legacy version, since I saw the purple boot screen... – Tuma Aug 21 '14 at 22:00
  • Be very careful on any reinstall. Only use Something Else or you may erase entire hard drive. Boot-Repair can convert a BIOS install to UEFI in advanced options by uninstalling grub-pc and installing grub-efi-amd64. How you boot installer is how it installs. Your UEFI/BIOS should show two options to boot flash drive or DVD. One will say UEFI and one usually just has label of flash drive, but does not say BIOS/CSM or legacy. – oldfred Aug 21 '14 at 23:44

I have had the same problem and you can make a virtual drive whit an virtualmachine VM whit windows 8 whir pre installed ubuntu, and then run boot-repair.

and it might work fine this way.

  • I have tried loading the trial version of Ubuntu from the usb again, and running boot repair but that didnt work. I got a pop up asking me if I wanted to replace WinEFI files. I clicked yes, and after the process was over, I got an error log, and a pop up informing me my computer is in legacy mode and I should change it to EFI – Tuma Aug 21 '14 at 20:01
  • To undo & to rename files to their original names, you just need to tick the "Restore EFI backups" option of Boot-Repair. When you run the rename, it renames the Windows efi boot file to actually be grub. Then only from grub menu can you boot the backed up copy of the Windows efi file. Then you cannot boot Windows directly from UEFI menu. You have to have secure boot off. Some systems required you to create a password in UEFI. If that is the case with your system never ever lose that password or you convert system to a brick. – oldfred Aug 21 '14 at 21:02

I have this exact ultrabook (Asus K46CB) and have managed to dual boot by doing so:

Go to Settings - Update and Recovery - Recovery. Under Advanced Startup, clic Reboot Now. After rebooting, go to Troubleshoot - Advanced Options - Windows Startup Settings and Reboot again. Then choose corresponding key (f1-f9) to Disable early launch anti-malware protection. Then reinstall grub (use a live CD).

That worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.