I have Ubuntu 12.04, which has been working great for me since I installed it a year ago.

Yesterday I ran the updates that update manager recommended. (Last time I ran updates before was about a week ago).

After the updates were installed, it asked me to reboot. So I rebooted it, and then it stopped at login prompt (as a command line, with no windows).

I logged in and tried to manually start the windows manager, and the screen went blank, and stayed blank I waited several minutes, and then turned it off.

How can I figure out what is the problem? Which logs should I check?


I checked /var/log/syslog and /var/log/lightdm/lightdm.log and I found an error message

FATAL: Module nvidia_331_updates not found.

So I tried to app-get it, and I listed all the nvidia packages, and apt-get says they are all already installed. See screenshot:

screenshot showing nvidia error

  • As I've suggested in my answer, try a apt-get install -f to make sure there is no broken package. I assume its not but you know assuming is not always right. When you are unstalling the drivers, a lot bg-work is done. When you updated and there was an error then the modules could not be build. So do a purge for the packages and then reinstall. If something fails you will see the reason. BTW do you have the standard kernel installed? If you are using the newest kernel that is not the dist default the drivers can't be build against that version. I had this two weeks ago. – wstein Aug 21 '14 at 21:06
  • apt-get install -f didn't do anything :( – ZSW Aug 21 '14 at 21:09
  • As I assumed :) but you never can be sure. So which kernel is installed? Do you now how to remove/purge packages from cmdl? If yes try that. Because when you indtall them again your system should build the modules against yout kernel. This was the behaviour on my system. When I reinstalled I could see why modules were not build. – wstein Aug 21 '14 at 21:14
  • Looks like my window manages is GNOME (my desktop looks like this pic: img.bhs4.com/58/3/…) – ZSW Aug 21 '14 at 21:27
  • Yes you are right but schould not make a difference since your log says nv module was not found. So what about reinstalling nv packages? – wstein Aug 21 '14 at 21:30

I would check ~ZSW/.xsession-errors first, and then check /var/log/lightdm/lightdm.log for any errors. If I had to guess, I would say it was a permissions issue, and that the lightdm user can't see the files it needs to be able to start properly.

  • I already checked .xsession-errors, and there's nothing useful there. Also, the problem is not specific to my account. – ZSW Aug 21 '14 at 14:59
  • What does /var/log/lightdm/lightdm.log say? What does /var/log/syslog say? – Zachary Aug 21 '14 at 16:53
  • I added info to the question. – ZSW Aug 21 '14 at 18:54

ok I would check /var/log/syslog and dmesg which will display kernel log.

wstein@valhalla:/home/wstein# sudo less /var/log/syslog
wstein@valhalla:/home/wstein# sudo dmesg

What a graphic-card are you using? Nvidia, Ati or Intel. I assume that drivers faild for install. Have you configured a framebuffer for grub? You can try an apt-get install -f which should try to repair broken packages. Hope that helps. Don't worry :)

So as you said in your comments it seems that the NVIDIA drivers failed for installing. As far as I know Ubuntu the NVIDIA modules are compiled against your installed kernel when you are installing the packages or a new kernel - since the modules are also provided to the ram disk grub is updated as well when you installing the drivers.

For Example, when I installed the newest kernel - which was not the Ubuntu 14.04 default - because I needed a patch for my BT adapter the installation went find but when the system booted I had the same problem as you. The reason was that the nvidia drivers could not be compiled against the new kernel. I saw that when I removed the nvidia packages and installed them again. For that you have two possibilities.

1) This example is for my system, you have to adapted the installed packages name. It could be that a reconfigure is not enough but you can try it:

wstein@valhalla:/home/wstein# sudo dpkg --get-selections | grep -v deinstall | grep 

nvidia-304-updates              install
nvidia-common                   install
nvidia-libopencl1-304-updates           install
nvidia-opencl-icd-304-updates           install
nvidia-settings                 install

wstein@valhalla:/home/wstein# sudo dpkg-reconfigure nvidia-304-updates

2) A way that should work (you also need to adapt it to your nv-package):

wstein@valhalla:/home/wstein# sudo apt-get purge nvidia-304-updates
wstein@valhalla:/home/wstein# sudo apt-get install nvidia-304-updates

It could be that this will work out of the box, but if not you will see what the problem is and can react over that. It could be that you might have to upgrade your system to the 14.04 LTS version if the drivers are not compatible with your default kernel. But don't worry. Try this solution for the moment and when it does not perform we'll take a look at it again :)

  • Since the fatal error message is related to nvidia, should I remove and reinstall nvidia packages? All of them? Just some? What's the simplest way to remove them? – ZSW Aug 21 '14 at 21:30
  • I didn't mess with grub and stuff like that. – ZSW Aug 21 '14 at 21:30
  • Ah ok you switched to this answer. Ok I am on my phone now but I think it was apt-get purge pack1 pack 2 ... Or it was dpkg -r but see man apt and man dpkg – wstein Aug 21 '14 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.