3

I'm running Ubuntu Studio 14.04 on my Macbook 3,1. It worked well until today. The internal keyboard doesn't work properly anymore. Most keys don't work at all, while a few produce the wrong characters. For example, the keys J, K and L produce the numbers 1, 2 and 3.

It's not a hardware issue, in Mac OS everything is still fine. My external keyboard also works correctly.

Can anybody help me?

  • 1
    I don't know why, but the problem was solved by pressing F6 twice. – user293132 Aug 21 '14 at 19:49
  • @Close voters - this is not unreproducible, I just reproduced it. It didn't go away on it's own ^^ he pressed F6! – Tim Aug 22 '14 at 17:12
  • @New close voters - this is perfectly clear - he accidentally enabled the number pad! – Tim Aug 28 '14 at 10:40
3

Solved by OP in comments

I don't know why, but the problem was solved by pressing F6 twice.

FYI, this is because the keyboard has a number pad built in. F6 disables this, and means you can type your letters rather than numbers.

enter image description here

Press the Caps Lock key. num. (F6) to activate the keypad.

Source

  • 1
    I don't have a Macbook Pro and there are no numbers on the keys, hence my confusion. I don't know how the numpad function got activated, I cannot reactivate the function with any of the shortcuts in the source. But I don't care, I don't need that anyhow. :-) – user293132 Aug 22 '14 at 23:52

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy